Question

No connection after reboot

I rebooted my droplet, as I’ve done before, but now I can’t connect to it with putty and pinging the IP address from outside results in timeout.

I can use the Console Access feature in Digital Ocean website. Executing e.g. ping 8.8.8.8 results in destination host unreachable messages.

Unfortunately I don’t have skills to troubleshoot this problem any further. Any suggestions for the next steps?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Had this problem a few times lately. One of the reasons was the default networking interface changed from eth0 to something else (don’t remember right now). The steps I took:

ifconfig -a

from there I can see which devices are available (sometimes this only works after a power cycle), in my case ‘eth0’

then edit /etc/network/interfaces with a static IP to correspond to that one, mine looks like this:

auto eth0
iface eth0 inet static
  address xxx.xxx.xxx.xxx # your droplet IP here
  netmask 255.255.255.0
  gateway xxx.xxx.xxx.1 
  dns-nameservers 8.8.4.4

your settings may vary, but this should correspond the original configuration that was on the droplet. the main point is to match the interface to whatever ifconfig -a outputs.

then it’s just a matter of calling

sudo service networking restart

I was missing ifupdown package, so I installed it with

apt install ifupdown

Also I needed to add eth0 static conf as stated by @herrmezz above.

To set network up manually, one could run the following commands on console:

ifconfig eth0 xxx.xxx.xxx.xxx # droplet IP
route add default gw xxx.xxx.xxx.1 # gateway ip
echo 'nameserver 8.8.8.8' > /etc/resolv.conf

I still had this problem but found a different solution which may help in the future. Check wether you have allowed ssh in ufw from the console sudo ufw status In my case I had not and rebooting the system enabled the firewall. So, from the console, you just have to

sudo ufw disable

and reboot. You should be able to ssh afterwards and make sur you have configured ufw properly.