Question

No credentials after creating droplet

This is getting very annoying! I created another user account because I have to create a website for a client and after creating my droplet, I did not receive any email with my credentials whatsoever. Customer support did not reply since I created my ticket two days ago. And yes, I checked every folder in my email account.

Please send out the user creds and fix this very common issue a lot of people seem to be experiencing.

Subscribe
Share

Hi digitalocean team,

I’m currently experiencing the same annoying issue. Upon creating account and making payments, I received email confirmations for the payment and also for DigitalOcean credit, but that for the credentials never came in.

Kindly rectify/advise on this problem, as it is for an urgent application that needs to be reviewed very soon.

Regards Gabriel

NOTE: I have added the support@support.digitalocean.com to my mailbox whitelist, even after receiving two separate mails from same address.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi there @vhendelmann,

In our public community, we aim to answer open questions about anything SysAdmin, DigitalOcean and beyond. However, we make every attempt to keep personal information safe and so don’t ever access personal account information here. This means we can’t provide help with any account or billing-related issues.

Do you have a ticket number from when you contacted our support team so that I can get this followed up for you?

Hope that helps! - Matt.

Sometimes emails might get bounced. You can try adding “support@support.digitalocean.com” to your whitelist/safelist and retry.