No Data Received Error In Magento

November 19, 2014 2k views

After changing the unsecure base_URL for one of my store views in backend, my entire magento site suddenly crashed resulting in a 'no data received' error on all pages of the site.

I've tried restarting apache which didn't fix the issue, I've clear the magento cache manually too.

Any help would be greatly appreciated!

  • How did you try to change the base_URL, through the control panel or by editing the database directly?

  • Actually at that point I had changed it from Magento backend settings.

    The domain is at where we just did a clean install of Magento, while using the current database, unfortunately the problem still persists.

  • yes we have.

    We have isolated the problem to happening when the magento cache is cleared.

    We did a clean install with a new droplet without any pre existing tables or files, everything was fresh.

    When we cleared the magento cache the site suddenly stopped working, give the 'no data received' error.

    I've been through this with support for the last 72 hours straight but they can't tell me if I'm not allocating enough resources, or i'm using too many resource, or a .conf file is not setup properly of if apache is not setup properly.

    Any idea it's really urgent now, my client changed over to digital ocean because of stability and even new droplets are crashing now.

2 Answers

If anyone else faces this problem here is how we fixed it:

first i set the compile to disable: php -f shel/compiler.php -- disable
next set the configcacheoptions to 0 all columns

We figure something went crazy with the compiler, which apparently isn't really required any more for Magento 1.6 or 1.7 and above.

When we cleared the cache everything just went crazy, even on new droplets.

Have another answer? Share your knowledge.