Question

No Data Received Error In Magento

Posted November 19, 2014 4.8k views

After changing the unsecure base_URL for one of my store views in backend, my entire magento site suddenly crashed resulting in a ‘no data received’ error on all pages of the site.

http://128.199.224.80/my/

I’ve tried restarting apache which didn’t fix the issue, I’ve clear the magento cache manually too.

Any help would be greatly appreciated!

3 comments
  • How did you try to change the base_URL, through the control panel or by editing the database directly?

  • Actually at that point I had changed it from Magento backend settings.

    The domain is at www.mymambaby.com/my where we just did a clean install of Magento, while using the current database, unfortunately the problem still persists.

  • yes we have.

    We have isolated the problem to happening when the magento cache is cleared.

    We did a clean install with a new droplet without any pre existing tables or files, everything was fresh.

    When we cleared the magento cache the site suddenly stopped working, give the ‘no data received’ error.

    I’ve been through this with support for the last 72 hours straight but they can’t tell me if I’m not allocating enough resources, or i’m using too many resource, or a .conf file is not setup properly of if apache is not setup properly.

    Any idea it’s really urgent now, my client changed over to digital ocean because of stability and even new droplets are crashing now.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

If anyone else faces this problem here is how we fixed it:

first i set the compile to disable: php -f shel/compiler.php – disable
next set the configcacheoptions to 0 all columns

We figure something went crazy with the compiler, which apparently isn’t really required any more for Magento 1.6 or 1.7 and above.

When we cleared the cache everything just went crazy, even on new droplets.

Submit an Answer