Question

No input file specified

Posted July 24, 2013 12.3k views
I dont know why i still get the "No input file selected" Can someone help me? This is my nginx http://pastebin.com/2HvkwnHi Why nginx cannot run the simple php page? I am running on Ubuntu 13.04
1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

5 answers
What's the contents of /usr/share/nginx/html and /etc/nginx/sites-enabled?

Also, I think the server_name needs to be changed to your domain name, e.g.
server_name yourdomain.tld www.yourdomain.tld instead of localhost.
Replied to your article comment: https://www.digitalocean.com/community/articles/how-to-install-linux-nginx-mysql-php-lemp-stack-on-ubuntu-12-04
by Etel Sverdlov
LEMP stack is a group of open source software to get web servers up and running. The acronym stands for Linux, nginx (pronounced Engine x), MySQL, and PHP. This tutorial explains how to install the required repos to download nginx and php-fpm, how to install MySQL, how to install nginx, how to install php-fpm, how to configure php and nginx, and how to create a php info page. This tutorial is written for Ubuntu 12.04.
i am doing this on localsite at the moment, the contents of /usr/share/nginx/html are
-50x.html
-ecard (folder with wordpress files)
-index.html (default nginx landing page, even this is not loading)
-info.php (simple php info file, even this is not processed by nginx)
-myapp (folder with custom php files)
-vendor (folder with custom php files)

The contents of /etc/nginx/sites-enabled is
-ecard (wordpress site)
Did you comment the following line out?

# fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;

Remove the '#' and restart nginx.
I did...but didnt solve the problem. Finally i just uninstall everything and reinstall the stacks. Problem solved
Submit an Answer