Question

No network connection from / to droplet

Hi, everybody

OS FreeBSD 10.1 Droplet was suspended 21th (due my vacation, was able to transfer funds 22th and powere it up) after that - no network connection. Created ticket, contacted support - nada. “You would pay before suspension, after that point - we not guaranty anything. Go to console, show us screenshots” - did it, no answer, asked again, answer: “We don’t provide any managed servers for free, if you pay us - we will help you with your problems”. Next day - “Can you go to console and show us screenshots?”. 30 hours after payed to them - no SSH, no FTP, no HTTP, droplet’s connection still suspended completely. OS was installed from their image, without any changes. Any suggestions?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I have had the issue also with CentOS. Seems that the recreation of a snapshot as a new droplet is an epic fail. tried multiple times and the external network does not work. I was able to connect the the box via the internal interface from another server and that allowed me to get my files… that is all.

Yesterday I’ve got access to Ubuntu(?) livecd at last.

Droplet dropped. Slow support.

Hello!

I have very similar issue as volgot, except network is gone after droplet migration, as I can see in droplet history and OS log files. The migration was done by DO staff and droplet has been restarted with no network.

Tried to set IP address manually - without success. Tcpdump shows that there are no ARP responses. No any incoming packets at all… Firewall is disabled.

I cannot even create new droplet from snapshot. Error message is: “Sorry! We’ve encountered an error creating your Droplet.”

Downtime for 3 days…!

Any help is appreciated.

There are a lot of non-productive comments on this thread. It’s not our place on the forums to lecture someone about their circumstances. We may never know the full reason behind the suspension, but the fact is that @volgot is a paying customer and fellow DO community member right now. By the same token, @volgot: you’re not likely to get much help if every response includes a jab at DO. Let’s have a reset here: if @volgot stops venting frustration at DO and we stick to advice/suggestions, we can focus on solving the problem. :)

I’ve never had this issue, but I also would have expected creating a new droplet from your snapshot to work. That’s probably worth retrying, but do it while your current broken droplet is running so you’re sure to get a new IP. When you tried/retry that, how are you trying to connect to the new droplet? For example, are you using a browser to access http://newip ?

Something that wasn’t clear to me from the problem description: are you having trouble with both inbound and outbound connections? You mentioned HTTP wasn’t working, but did you mean inbound HTTP requests to your web server and/or outbound HTTP requests using a tool like curl? What are you doing to test inbound/outbound connections and what are the results of each?

Past that, as was stated above, you’ll need to troubleshoot the network connection. Perform a fresh reboot before starting these steps, because you wouldn’t want commands you’ve already ran post-boot to affect the output, get a resolution, and then reboot into the same issue again.

Please paste the output of the following commands so we have some basic details to start with:

ifconfig netstat -rn netstat -an | grep -i listen

Can you perform DNS lookups and pings? Show us the output from:

host www.google.com ping -c 1 www.google.com

What’s in these files?

/etc/rc.conf /etc/resolv.conf

Is the problem resolved by shutting down your firewall? If you’re using pf, shut it down and try in/out connections again:

service pf stop

If you’re not able to resolve this issue, are you going to lose files/data? In thinking of what you could do if you’re not able to resolve it: Would it be possible to add a block storage device to the broken droplet, copy your files to it, and then connect that block storage device to a fresh droplet to get your files? I’ve never used DO’s block storage feature, so I don’t know if that would work or not.

What do you get when you run “systemctl restart networking”

What do you get when you run “systemctl restart networking”

Ok, if ppl don’t pay at time, their droplets became unworkable? Need just to know

Ppl, I need to bring my network back to the droplet, or move all files from it. Had anybody same issues, maybe?

What do you get when you run “systemctl restart networking”

Also by using digitalocean you’re required to pay in advance, not only that you’re given more than enough notice to pay off existing debts if you’ve not filled your balance in advanced.