Question

No puedo cambiar el teclado de mi servidor a uno español. He seguido las configuraciones oportunas pero no ha dado resultado

Buenas, estoy intentado poner el teclado de mi servidor al español, el keyboard layout.

En teoria está configurado pero no funciona. Si ejecuto el comando ‘locale’ obtengo todo en ‘es_Es.UTF-8’ que es asi como lo he querido configurar. Pero no parece surtir efectos ya que comandos como ‘shift + 7’ no pone ‘/’ sino ‘_’.

No se que mas podria probar.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @joseangelcabezarn,

You mentioned you’ve configured the locale however please go over these steps one more time and see if it would help you out:

The default settings are stored in the /etc/default/locale file.

$ cat /etc/default/locale 
LANG=en_US.UTF-8

This file can either be adjusted manually or updated using the tool, update-locale.

# update-locale LANG=de_DE.UTF-8

You will find a list of all LC_* environment variables at [1].

This becomes useful for example when a system should be operated in German, however, the error and system messages should be displayed in English. This is often helpful when searching for errors. In this case, the following settings can be made to /etc/default/locale:

LANG=de_DE.UTF-8
LC_MESSAGES=POSIX

The LC_MESSAGES variable also influences the language of the user interface or the window manager.

Please note:

Date and number specifications are not affected by a change from LC_MESSAGES.

Regards, KFSys