Question

Node app runs correctly on Ubuntu VPS with LAMP, but not a standard Ubuntu VPS

I’m trying to run a nodejs app on a VPS, but a function in the app that uses the request module (making a HTTP request) is not working on a standard VPS running Ubuntu 20.04.

However when I run the same app on a similar server but with the DO Marketplace LAMP installation, the request runs fine.

I’ve checked the ufw settings and they’re the same so I don’t think it’s that.

I’m still fairly new to node so would appreacite any help I can get. Thanks.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

What are the exact errors that you get when you try to run the service?

I could suggest following the steps including the prerequisites from this tutorial here:

https://www.digitalocean.com/community/tutorials/how-to-set-up-a-node-js-application-for-production-on-ubuntu-20-04

Regards, Bobby