Question

[NODEJS] Sockets disconnecting before secure TLS connection can be established.

I was trying to call some APIs through my Droplet as a test, and I ran into some very odd errors: “Client network socket disconnected before secure TLS connection was established” and “SOCKETTIMEOUT” To make sure this was not the fault of my code, I ran it on both a local Windows and a Linux machine, and I had no problems. What could be causing the issue? The Linux machine had essentially the same configuration as the droplet, yet still ran it without error. So far, I have tried switching all https to http, without success.

test script: const axios = require(‘axios’) axios.get(‘path-to-api’,{params:{}}) .then((rsp)=>{ console.log(‘Got sucessful response!’) }) .catch((err)=>{ console.log(err) })

Droplet info: ubuntu 20.04 LTS Nodejs 15.3.0

Test Machine (Windows) info: Windows 10 (latest) Nodejs 15.3.0

Test Machine (Linux) info: ubuntu 20.04 LTS Nodejs 15.3.0

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Did you ever find a solution?

I’m having the same issue; only on the droplet but not from my PC or other server. Could someone from DigitalOcean shine some light on this perhaps?