NoSuchKey - Build error on severless application

Hello, after update code I am receiving error code during building an application.

<Error> <Code>NoSuchKey</Code> <BucketName>appbuild-logs</BucketName> <RequestId>tx0000000000001d23f97e1-0062e6d63c-2afd02cc-nyc3b</RequestId> <HostId>2afd02cc-nyc3b-nyc-zg02</HostId> </Error>

so I tried to rebase the previous code, but building process always return same error message.

We are trying to develop a serverless application, which worked for us up to a certain point.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
August 22, 2022

Hi there,

As even after reverting to a previous working commit does not fixes the issue, can you confirm if you’ve made any changes to your appbuild-logs Spaces bucket?

Judging by the error, it seems like that the bucket that you’ve been using is no longer available. I could suggest making sure that the bucket name is correct or re-creating the bucket in case that it is missing.



Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up