Not able to deploy ROOT.war in tomcat 7

February 16, 2014 8.6k views
I have purchased DigitalOcean server and I am trying to run a java application. I am using ubuntu OS and tomcat 7 server where my webapps folder is located in : /usr/share/tomcat7 Now, I have scp my ROOT.war in the folder and restarted tomcat server and apache. But my application is not running. In the file catalina.2014-02-09.log, it shows: Unable to create the directory [/usr/share/tomcat7/webapps/ROOT/META-INF] at org.apache.catalina.startup.ExpandWar.expand( at org.apache.catalina.startup.ContextConfig.fixDocBase( at org.apache.catalina.startup.ContextConfig.init( at org.apache.catalina.startup.ContextConfig.lifecycleEvent( at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent( at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent( at org.apache.catalina.util.LifecycleBase.setStateInternal( at org.apache.catalina.util.LifecycleBase.init( at org.apache.catalina.util.LifecycleBase.start( at org.apache.catalina.core.ContainerBase.addChildInternal( One more error I see in the same log is : java.lang.IllegalStateException at org.apache.catalina.loader.WebappClassLoader.loadClass( at org.apache.catalina.loader.WebappClassLoader.loadClass( at org.hibernate.dialect.MySQLDialect$1.convert( at org.hibernate.exception.internal.StandardSQLExceptionConverter.conver I am not able to understand what can be the cause of this issue? As per , I have configured server.xml for unpack war as But still no results. Please help me out here. Any suggestions can be helpful.
1 comment
  • I am also facing similar issue, in my case no exception but it hangs at
    INFO: Deploying web application directory /root/apache-tomcat-7.0.50/webapps/host-manager

3 Answers
Did you try to deploy your War file over tomcat interface?

I had something similar, my application was trying to create a file so had the IOException. It turned out to be that the tomcat is installed with Root user but the user for running tomcat is Tomcat. I changed the permissions on the tomcat directory in question to have write permission as well as execute and read and then it worked ok. Hope that helps

  • Agreed, I had a similar problem and it was resolved by doing (in /opt/tomcat/):
    sudo chgrp -R tomcat webapps
    sudo chmod g+rwx webapps
    sudo chmod g+r webapps/*

I have the same problem, with a clean tomcat installation server is not starting. any clues?

Have another answer? Share your knowledge.