Not able to login in ftp through shell

July 4, 2013 2k views
Hi, after installing vsftpd on centos, I am not able to login with my root username and pwd.=error msg->"530 permission denied Login failed". How do I add user to multiple domain names for ftp. And how do I make the default home directory to var/www/ Thanks for help in advance
3 Answers
Logging into FTP using root is very dangerous - vpsftpd might not allow it.. Create a new user and login using that.
Make sure the port is set to 22. Check [this answer](http://superuser.com/a/40483/133969) about changing your home directory.

"Make sure the port is set to 22."



From a security point of view, the consensus seems to be that it's best to manually change the SSH port (22) to something else (i.e., a random port no.). See Initial Server Setup with Ubuntu 12.04

by Etel Sverdlov
This tutorial covers how to login with root, how to change the root password, how to create a new user, how to give the new user root privileges, how to change the port, and how to disable root login in. This tutorial is written for Ubuntu. When you first create your server, this tutorial explains the first steps you need to take. This tutorial is written for Ubuntu 12.04.
Have another answer? Share your knowledge.