Question

Not able to login through putty to droplet - I received connection refused error

  • Posted January 9, 2015

I created a new droplet in SG. Not able to login through putty. It says connectin refused and gets shut down. I tried to ssh from another unix nstance with ssh root@128.XXX.XXX.XXX I got “Connection Refused” error Please help me resolve as working through console is very pain ful

Subscribe
Share

While logged in at the web console, run

 tail -f /var/log/auth.log

Then from Putty, try to log in. Note any error messages that have the IP address of where your Putty session originates from.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Is root Login enabled?

$ sudo nano /etc/ssh/sshd_config
PermitRootLogin yes

$ sudo service ssh restart

It should be enabled on your first boot but maybe they changed it to deny. If it is that go ahead and enable it, make a new account (say john), add him to the sudo group & try to login with that account. If it works you can then disable root login.

I tried the Ubuntu set up steps ate: https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-12-04 The error I am gettin gis: Connection closed by 128.XXXXXXX