Not receiving root password

  • Posted on November 11, 2014
  • VarsAsked by Vars


I created a new droplet yesterday but still have not received the root password in my email. I tried resetting the root password as well as create that droplet again but still no email. I have received emails from digital ocean before and they do not appear in my spam folder. Any ideas why I’m not receiving my root password?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Did you set up the droplet with a SSH key? If you do this, no password will be sent to you, you SSH in using the key and then run “passwd” to change it to one of your choosing.

If someone from future comes across the same issue here’s how I solved it.

  1. I went to the specific droplet page. eg. Droplets->[droplet name].
  2. Selected recovery option from the menu and select “Boot from recovery ISO”.
  3. Switched off droplet using the “On/Off” button on top.
  4. After it turned off, I re-pressed the button to turn it on.
  5. Then Clicked on “Console” button on top.
  6. After opening the console I got 6 options to select in the console window. I first selected “1” and enter to mount the disk image.
  7. Once mounted, I entered “3” to reset droplet root password.
  8. Tada!!! I was prompted to enter the new password twice.
  9. After everything done, Go back to recovery option and select “boot from Hard drive” option.
  10. Turn it Off and On again
  11. Done. I was able to access the droplet from my terminal.

Hope this helps. I’m Using Debian 9 as the OS.

I too experienced this problem with initial creation of the droplet. However, resetting the droplet’s root password triggered the email.

Until the issue is fixed, try this:

  1. create your droplet
  2. goto > Droplets > Access
  3. Reset Root Password

Check your email, you should have received the access password. At least I did.