Not receiving root password

Posted November 11, 2014 21.2k views


I created a new droplet yesterday but still have not received the root password in my email. I tried resetting the root password as well as create that droplet again but still no email. I have received emails from digital ocean before and they do not appear in my spam folder. Any ideas why I’m not receiving my root password?

  • I just checked and it looks like the emails were successfully sent. Did you check your Spam/Junk folder in case they accidentally ended up in there?

  • I am having same problem . Still didn’t receive email for root password

  • This problem just happened with me aswell, took untill after I had given up waiting and deleted the droplet before the password arrived....

  • Having exactly the same issue now. Requested password 3 times. No email as of yet. Infuriating!

  • The same problem. No email. Checked in junk mail as well!

  • Show 13 more comments

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
16 answers

Did you set up the droplet with a SSH key? If you do this, no password will be sent to you, you SSH in using the key and then run “passwd” to change it to one of your choosing.

If someone from future comes across the same issue here’s how I solved it.

  1. I went to the specific droplet page. eg. Droplets->[droplet name].
  2. Selected recovery option from the menu and select “Boot from recovery ISO”.
  3. Switched off droplet using the “On/Off” button on top.
  4. After it turned off, I re-pressed the button to turn it on.
  5. Then Clicked on “Console” button on top.
  6. After opening the console I got 6 options to select in the console window. I first selected “1” and enter to mount the disk image.
  7. Once mounted, I entered “3” to reset droplet root password.
  8. Tada!!! I was prompted to enter the new password twice.
  9. After everything done, Go back to recovery option and select “boot from Hard drive” option.
  10. Turn it Off and On again
  11. Done. I was able to access the droplet from my terminal.

Hope this helps. I’m Using Debian 9 as the OS.

I too experienced this problem with initial creation of the droplet. However, resetting the droplet’s root password triggered the email.

Until the issue is fixed, try this:

  1. create your droplet
  2. goto > Droplets > Access
  3. Reset Root Password

Check your email, you should have received the access password. At least I did.

I had this problem as well. I never received the original root password via email, it wasn’t in my inbox, sub folders, or spam.

I reset the root password and actually received the pw email. Then I tried to login with it three times, no luck. I waited five minutes and tried again, and it worked! Seems like black magic to me. Anyway, try resetting the root password and give it 10 minutes or so.

Did not receive root password too even if I Reset Root Password three times.

I also looked in junk folder but nothing was there… Could you solve that issue ?

Same problem. Waiting for the password

I solved this problem shutting down the droplet before reset the password.

This is ridiculous! One year later since the OP and still the same??

Same issue here. No emails :(

Previous 1 2 Next