Not receiving root password

  • Posted November 11, 2014


I created a new droplet yesterday but still have not received the root password in my email. I tried resetting the root password as well as create that droplet again but still no email. I have received emails from digital ocean before and they do not appear in my spam folder. Any ideas why I’m not receiving my root password?


I am having same problem . Still didn’t receive email for root password

I just checked and it looks like the emails were successfully sent. Did you check your Spam/Junk folder in case they accidentally ended up in there?

i dunno but this method works on me :

  1. when create new droplet, don’t add new ssh key or tick the checkbox of previous key. leave it behind( if u ever create droplet before).

you’ll get the email

…and the issue continues. It has been a hour now. Haven’t received the email with the password. No I didn’t set up SSH. No it’s not in a spam folder. Yes I tried resetting the droplet password.

Can anybody help me?

same here!..

The same issue now. I Requested password 3 times, but no email as of yet.

How exactly do we use the SSH private key with PuTTY?

I made a droplet about 30 minutes ago. Haven’t received the email with the password. No I didn’t set up SSH. No it’s not in a spam folder. Yes I tried resetting the droplet password.

Not sure what the problem is. Considering how nice the rest of the digital ocean experience has been I wish this would be too.

Might have to call customer service, if I can find the number…

I cant delete droplet. I have there 15 sites. But I reseted root password 5 times, but after 2 hours I didnt get mail. I thought its problem on my side, I tried to change mail in DO admin to gmail mail. It said that confirmation mail was sent to my mail but even that confirmation mail didnt come… I am desperate, I am not able to connect to my console, it asks for password that I didnt get… Nobody answering to my tickets…f************k

Me too. I just created a new droplet 30 minutes ago and have yet to get the “New Droplet” email with my credentials

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Did you set up the droplet with a SSH key? If you do this, no password will be sent to you, you SSH in using the key and then run “passwd” to change it to one of your choosing.

If someone from future comes across the same issue here’s how I solved it.

  1. I went to the specific droplet page. eg. Droplets->[droplet name].
  2. Selected recovery option from the menu and select “Boot from recovery ISO”.
  3. Switched off droplet using the “On/Off” button on top.
  4. After it turned off, I re-pressed the button to turn it on.
  5. Then Clicked on “Console” button on top.
  6. After opening the console I got 6 options to select in the console window. I first selected “1” and enter to mount the disk image.
  7. Once mounted, I entered “3” to reset droplet root password.
  8. Tada!!! I was prompted to enter the new password twice.
  9. After everything done, Go back to recovery option and select “boot from Hard drive” option.
  10. Turn it Off and On again
  11. Done. I was able to access the droplet from my terminal.

Hope this helps. I’m Using Debian 9 as the OS.

I too experienced this problem with initial creation of the droplet. However, resetting the droplet’s root password triggered the email.

Until the issue is fixed, try this:

  1. create your droplet
  2. goto > Droplets > Access
  3. Reset Root Password

Check your email, you should have received the access password. At least I did.

Same problem, no password, no access - come on already “Digital Ocean” - enough is enough

Had a similar problem…What worked for me is

  1. Destroy current droplet 2.Create a new droplet BUT

    -Don’t assign any SSH keys during creation -Don’t enable backups during creation

  2. Create droplet and wait for the email. You should receive it within 15 minutes or less.

This comment has been deleted

After adding the ssh key to a Droptlet , I also didn’t recieve any email, Before adding ssh i recived every mail with credentials but now Nothing. What to do??

Same problem here…i made the Droplet i have no receive root pass, Reset Root Password three times but no answer!!!

no inbox, no junk no everywhere !!!

This comment has been deleted

Same issue here. No emails :(