npm install are very slow in sg server

Posted October 13, 2020 2.6k views

Hi few days ago I had created a droplet in sg, one thing I notice is when I run npm install it get stucks on oarticular model , it taks like an hour coule not even finished , I encounter in my laravel and vuecli app.I used ny server before and deploy vuecli app didnot encounter this issue , are there any troubleshooting I can make thanks.
this is how i install node via os package ?
i tried to delete the node_model folder start again but it did not help

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Mine was getting stuck at 70% of npm or yarn prod. but restarting ubuntu sudo reboot solved it

Hi @stupidboy,

I had a similar problem. The reason was wrongly configured proxy and because of that npm was unable to download packages.

So your best bet is to see the output of

npm install --verbose

and identify the problem. Most probably the issue is - permissions are not sufficient for npm to modify files.


  • hi sorry for the late reply , i will try what you had suggested thanks

  • hi this is what I come up after I ran the command.

    npm info it worked if it ends with ok
    npm verb cli [ ’/usr/bin/node’, ’/usr/bin/npm’, ‘install’, ’–verbose’ ]
    npm info using npm@6.14.5
    npm info using node@v12.18.2
    npm verb npm-session 7db428619353896b
    npm info lifecycle weather-app@0.1.0~preinstall: weather-app@0.1.0
    [ .................] | preinstall:weather-app: info lifecycle weather-app@0.1.0~preinstall: weather-app@0.1.0

    and it gets stuck.

    • Hi @stupidboy,

      Hmm, that’s really odd. After that, does it should another package that it’s trying to preinstall or is having trouble connecting to?

      If not, I’ll suggest turning your attention to

      [ .................] | preinstall:weather-app: info lifecycle weather-app@0.1.0~preinstall: weather-app@0.1.0

      Something is indeed causing this delay, maybe it can’t reach to some resource and this waiting for a timeout.