deskha
By:
deskha

One droplet, One Vesta, Multi domain and mail servers settings

January 19, 2015 3k views

It's been almost two weeks that i kept failing to configure mail server.

I have one droplet with name,let's say 'mydroplet', 1Gb Ram, 30Gb SSD and Ubuntu 12.04.5 x32 and successfully installed Vesta there
I have successfully put several domains and sub-domains there and manage to bring the transferred website alive again (they were on shared hosting previously)

The only thing i failed is making the mail to work

I have configured the DNS on digital ocean with MX record
For example, for mydomain1.com, i put 10 mail.mydomain1.com, for mydomain2.com i put 10 mail.mydomain2.com .

I still don't know how to configure the MX records for the subdmomain (for example for sub.mydomain1.com, should i put it as 10 mail.sub.mydomain1.com(??) ? )

I can add the email address in vesta and access it through roundcube. I can even send email from there to my gmail accounts but i can't receive any.

For additional info, my old hosting is still alive and i can still open the old email squirell through its IP (xxx.xx.xxx.xxx:2095) but i found no new or recently received email there also.

Its been almost 2 weeks...and i think i'm almost desperate......any suggestion and help?

1 Answer

Make sure you have a matching A record for mail.mydomain1.com. This should be your droplets ip address.

Also I don't think DO DNS allows sub-domains for MX records. At least I haven't figured it out either.

  • thank you for answering
    I create the A record for the mail.mydomain1.com but i haven't yet successfully receive any email...

    Any suggestions peeps?

  • Without knowing your domain name not sure I can think of anything else to try.

    Does the server send mail locally? User A to User B on same domain same server?

  • sorry for the very late reply, i figured all using Vesta

    Thank you

    • Could you give a hint on how did you fix this? I have a fresh install of Vesta and proper MX dns setup but can't receive external emails either.

      Thank you

    • I'm having exactly the same problem. Would appreciate some idea of how you fixed it

Have another answer? Share your knowledge.