Question

Open Port 9001 for socket.io on Ubuntu Cyberpanel droplet.

I’m trying to run a Webrtc application and I need to open ports 9001, 3478 and 5349 on my ubuntu droplet. As you can see in the attached images, I’ve already set up Digitalocean firewall and added the ports to the ubuntu machine too. However, I still have a connection timeout error for socket.io on port 9001. Any idea on how to solve this issue? https://ibb.co/9TBWgsM https://ibb.co/BVFyM0f https://ibb.co/j5SKNX2 https://ibb.co/bsBXgRx https://ibb.co/bNHbHpC https://ibb.co/q0sp51c


Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @sergiowilliones,

Depends on the feature you use, you need to open the following ports:

  • TCP Port 443 (HTTPS): outbound
  • UDP and TCP port 3478 bidirectional to the WebRTC server
  • UDP Ports 50,000 – 65,535 (RTP/sRTP/RTCP) bidirectional to the WebRTC peers. These ports are optional; if blocked, media will be proxied using TURN on port 3478

Do you use the transmission of secured streaming media (audio)? in this case, you’ll need to open udp/16384-32768.

Let me know how it goes,

Sergio Turpín