Openlitespeed: URL not redirecting to HTTPS but domain is

Posted March 18, 2021 1.2k views
OpenLiteSpeed WordPress 1-Click

If i put in address bar it goes to
But if i put it doesn’t redirect to https version.

For some reason all my pinterest links have become http and all my traffic is going there and not the https version.

I have setup the listener and virtual hosts as per this guide in the litespeed web console

Also have added these rewrite rules in the virtual host

RewriteCond %{SERVERPORT} 80
RewriteRule ^(.)$$1 [R,L]
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:X-Forwarded-Proto} !https
rewriteRule ^(.
)$ https://%{HTTP

note: in the above is replaced with my domain, rest is as it is.

Can someone please help?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

It might be due to the rewrite, please share your Environment Report: Navigate to LiteSpeed Cache > Toolbox > Report, press the Send to LiteSpeed button, and let us know what it says under “Report Number.” I’ll be able to access the report from here and get some information about your configuration that might be helpful.

  • Thanks. Just generated the report.
    Report number: OQCFPAEQ

    • Thanks. It shows 404 if I just visit the site with HTTP, which possibly due to incorrect or non-set HTTP listener mapping to the virtual host, not because of the rewrite/redirect. If you still can’t fix it, please send the issue to with temporary web admin access so we can help you further.

      • I mapped the http listener to virtual map. Now
        If i share the url without https, that is redirecting to https. goes to and that solves my issue.

        However if I open with http in the url, it still doesn’t redirect to https. I’m not sure if that’s how it should be. But my main issue is solved now. Thank You very much.

May I know if your WordPress Home URL and Site URL start from HTTPS?