Question

OpenSSL implementation... what am I missing?

HelIo,

I have been working really hard on installing an OpenSSL certificate so my web-app can show the beautiful “HTTPS” in the URL, but it is not working.

I used this guide: https://www.digitalocean.com/community/tutorials/how-to-create-a-ssl-certificate-on-apache-for-ubuntu-14-04

I have a Linux VPS with Ubuntu 14.04 and Apache 2.4.7.

These is what’s been done so far:

1.- Enable SSL module:

sudo a2enmod ssl

2.- Restart Apache:

sudo service apache2 restart

3.- Create SSL directory inside de Apache2 directory:

sudo mkdir /etc/apache2/ssl

4.- Execute the following command to create a self-signed ssl certificate :

sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/apache2/ssl/apache.key -out /etc/apache2/ssl/apache.crt

5.- Fill in questions:

Country Name (2 letter code) [AU]:US State or Province Name (full name) [Some-State]:New York Locality Name (eg, city) []:New York City Organization Name (eg, company) [Internet Widgits Pty Ltd]:Your Company Organizational Unit Name (eg, section) []:Department of Kittens Common Name (e.g. server FQDN or YOUR name) []:your_domain.com Email Address []:your_email@domain.com

6.- Configure apache to utilize ssl:

sudo nano /etc/apache2/sites-available/default-ssl.conf

7.- Modify the following data:

ServerAdmin admin@example.com ServerName my_domain.com ServerAlias www.my_domain.com DocumentRoot /var/www/html SSLCertificateFile /etc/apache2/ssl/apache.crt SSLCertificateKeyFile /etc/apache2/ssl/apache.key

8.- Enable “default-ssl.conf” file:

sudo a2ensite default-ssl.conf

9.- Restart Apache again:

sudo service apache2 restart According to what I have read that should be all… what am I missing??

Thank’s in advanced.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

To whom may be interested in this question I want to let you know that I could finally resolve the problem. It was an ip table rule that was blocking port 443.

  • The steps mentioned above are correct :)

This comment has been deleted

The steps look correct. Is your website not loading at all when you browse to https://yourdomain.com or are you getting an error?