Question

OpenVPN Internet Speed around 22Mbps - normally +100Mbps, Why?

Hi,

I’ve used OpenVPN before on my droplet without any issue (fast internet connection). However, since my old computer crashed I bought a new one and I set up exactly the same VPN in this machine, but for some reason the internet speed is awfully slow. Basically nothing changed but my computer, even OS is exactly the same (ubuntu 16.04 LTS)

Is there anything I could try to fix this slow connection problem? I don’t think the problem is in the droplet because that would not make any sense, since the droplet have been untouched the whole time. So I’m assuming that the problem occurs because of my new computer settings/drivers or something along those lines, is that possible? And if so, where you suggest me to start investigate this issue?

Subscribe
Share

The very weird thing is that the very first internet action works normally, for example, a google search, but after a couple of seconds it slows down drastically.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

You could try ifconfig (or similar if you aren’t running linux) and look for errors. More overkill, you could run wireshark. My guess is retransmitted packets due to who knows what.

This comment has been deleted