OpenVPN Internet Speed around 22Mbps - normally +100Mbps, Why?

March 9, 2018 166 views
VPN Ubuntu 16.04


I've used OpenVPN before on my droplet without any issue (fast internet connection).
However, since my old computer crashed I bought a new one and I set up exactly the same VPN in this machine, but for some reason the internet speed is awfully slow. Basically nothing changed but my computer, even OS is exactly the same (ubuntu 16.04 LTS)

Is there anything I could try to fix this slow connection problem?
I don't think the problem is in the droplet because that would not make any sense, since the droplet have been untouched the whole time. So I'm assuming that the problem occurs because of my new computer settings/drivers or something along those lines, is that possible? And if so, where you suggest me to start investigate this issue?

1 comment
  • The very weird thing is that the very first internet action works normally, for example, a google search, but after a couple of seconds it slows down drastically.

2 Answers

You could try ifconfig (or similar if you aren't running linux) and look for errors. More overkill, you could run wireshark. My guess is retransmitted packets due to who knows what.

  • Hi, thanks for your reply.
    I solved my issue by reconfiguring my client settings.
    My client machine is ubuntu and I needed to add these settings:

    script-security 2
    up /etc/openvpn/update-resolv-conf
    down /etc/openvpn/update-resolv-conf

    For some reason, I missed that since I did not set up my VPN manually. At first, I did but recently moved to using a script instead, because VPN set up throw weird errors.

    Weirdly enough, speed test still shows me that I'd have 23.40Mbsp even that my connection works smoothly now.

Have another answer? Share your knowledge.