Question

OpenVPN - IPv6 works only in local network

Posted January 2, 2015 20.4k views

Hello everyone,

I have dual stack OpenVPN server:

IPv4 works fine, but IPv6 works only in local network.
I would like to access the IPv6 Internet through my VPN.

Server eth0 IP: 2a03:b0c0:1:d0::7f:8001/64
Server tun0 IP: 2a03:b0c0:1:d0::7f:8002/64
Client tun0 IP: 2a03:b0c0:1:d0::7f:8003/64

Server

ip6tables

Chain INPUT (policy DROP 240 packets, 19200 bytes)
 pkts bytes target     prot opt in     out     source               destination         
   32  6574 ACCEPT     all      lo     *       ::/0                 ::/0                
  167 14920 ACCEPT     icmpv6   *      *       ::/0                 ::/0                
   36  3242 ACCEPT     udp      *      *       ::/0                 ::/0                 udp dpt:53
    6   481 ACCEPT     tcp      *      *       ::/0                 ::/0                 tcp dpt:53
    0     0 ACCEPT     tcp      *      *       ::/0                 ::/0                 tcp dpt:22
    0     0 ACCEPT     tcp      *      *       ::/0                 ::/0                 tcp dpt:1194
  246 28608 ACCEPT     all      *      *       ::/0                 ::/0                 state RELATED,ESTABLISHED

Chain FORWARD (policy ACCEPT 15 packets, 1560 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 569 packets, 91798 bytes)
 pkts bytes target     prot opt in     out     source               destination  

server.conf

mode server
tls-server
proto tcp-server
dev tun0
tun-ipv6
topology subnet

client-to-client
ifconfig 192.168.192.1 255.255.255.0
ifconfig-ipv6 2a03:b0c0:1:d0::7f:8002 2a03:b0c0:1:d0::7f:8001
client-config-dir /etc/openvpn/ccd

ccd/client

ifconfig-push 192.168.192.3 255.255.255.0 # vps
ifconfig-ipv6-push 2a03:b0c0:1:d0::7f:8003/64

push "route-ipv6 2a03:b0c0:1:d0::7f:8001/64"
push "route-ipv6 2000::/3"

sysctl.conf

net.ipv6.conf.all.forwarding=1

Client

client.conf

remote shark.pdostal.cz 1194
proto tcp
tls-client
dev tun1
tun-ipv6
proto tcp-client
remote-cert-tls server

pull

Both server & client configs

<certificates>

keepalive 10 30

comp-lzo
persist-key
persist-tun

verb 2

Do you have any idea what is wrong?
Thanks you for your help!

5 comments

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Anyone solved this problem?

Okay, I solved this problem. Tested on clean OpenVPN installed by that tutorial: https://www.digitalocean.com/community/tutorials/how-to-set-up-an-openvpn-server-on-ubuntu-14-04

We need to create another subnet(?) for OpenVPN, so in /etc/openvpn/server.conf add:
server-ipv6 ANYIPV6::/112

I used my server IP replacing two colons in it for one and adding at the end :80::/112

Now create rule:
ip6tables -t nat -A POSTROUTING -s YOURANYIPV6/112 -j SNAT –to YOURSERVER_IP

And remember, in /etc/sysctl.conf uncomment:
net.ipv6.conf.all.forwarding = 1

Restart, reconnect and check test-ipv6.com. This site shows problem with big MTU, but I don’t know now how to solve it

BTW sorry for my bad english.

by James
OpenVPN is a full-featured open source Secure Socket Layer (SSL) VPN solution that accommodates a wide range of configurations. In this tutorial, we'll set up an OpenVPN server on a Droplet and then configure access to it from Windows, OS X, iOS and Android. This tutorial will keep the installation and configuration steps as simple as possible for these setups.
  • So you recommend me to hide all my IPv6 clients behind the NAT?

    I’ll try it, but at the end I’d like to have public IPv6 address on every client.

  • DigitalOcean provide only 16 public IP’s for each droplet. I think this is too small to make each client public IP, but i’m not an expert.

  • Thank you so much for this. Your instructions are actually working perfectly (test-ipv6 is happy for me). Excellent interim solution until DO gets their act together and properly supports real IPv6 subnets.

    I would recommend adding the following to your openvpn server configuration file:
    push “redirect-gateway ipv6” #For iOS9
    (helps with iOS 9 problems and does not seem to hurt for other clients)

In CCD do

iroute-ipv6 2a03:b0c0:1:d0::7f:8001/64
iroute-ipv6 2000::/3

instead of
push “route-ipv6 2a03:b0c0:1:d0::7f:8001/64”
push “route-ipv6 2000::/3”

Submit an Answer