Openvpn Server connection problem?

November 4, 2013 23k views
Hello, I have setup a Openvpn server when i connect to it thru Openvpn GUI(on windows computer) it connect to vpn,authenticate and then it says connected but the address is not the remote address of my server instead it is the internal address which is: 10.8.0.6. i´m not enable to use the openvpn connection since it says that there is no internet connection on Network connection 2 which the openvpn created on my windows computer. I wonder whats wrong? Here is the log: " Mon Nov 04 21:24:02 2013 Warning: cannot open --log file: C:\Program Files\OpenVPN\log\blackcloud.log: Denied Access. (errno=5) Mon Nov 04 21:24:02 2013 OpenVPN 2.3.2 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Aug 22 2013 Mon Nov 04 21:24:02 2013 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340 Mon Nov 04 21:24:02 2013 Need hold release from management interface, waiting... Mon Nov 04 21:24:02 2013 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340 Mon Nov 04 21:24:02 2013 MANAGEMENT: CMD 'state on' Mon Nov 04 21:24:02 2013 MANAGEMENT: CMD 'log all on' Mon Nov 04 21:24:02 2013 MANAGEMENT: CMD 'hold off' Mon Nov 04 21:24:02 2013 MANAGEMENT: CMD 'hold release' Mon Nov 04 21:24:08 2013 MANAGEMENT: CMD 'username "Auth" "zyry"' Mon Nov 04 21:24:08 2013 MANAGEMENT: CMD 'password [...]' Mon Nov 04 21:24:08 2013 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info. Mon Nov 04 21:24:08 2013 Socket Buffers: R=[8192->8192] S=[8192->8192] Mon Nov 04 21:24:08 2013 UDPv4 link local: [undef] Mon Nov 04 21:24:08 2013 UDPv4 link remote: [AF_INET]146.185.165.114:1194 Mon Nov 04 21:24:08 2013 MANAGEMENT: >STATE:1383596648,WAIT,,, Mon Nov 04 21:24:08 2013 MANAGEMENT: >STATE:1383596648,AUTH,,, Mon Nov 04 21:24:08 2013 TLS: Initial packet from [AF_INET]146.185.165.114:1194, sid=a8451bea aa92fab3 Mon Nov 04 21:24:08 2013 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this Mon Nov 04 21:24:08 2013 VERIFY OK: depth=1, C=NL, ST=North Holland, L=Amsterdam, O=BlackCloud, OU=BlackCloud, CN=BlackCloud Vpn, name=BlackCloud, emailAddress=info@wh.nu Mon Nov 04 21:24:08 2013 VERIFY OK: depth=0, C=NL, ST=North Holland, L=Amsterdam, O=BlackCloud, OU=BlackCloud, CN=BlackCloud, name=BlackCloud, emailAddress=info@wh.nu Mon Nov 04 21:24:11 2013 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key Mon Nov 04 21:24:11 2013 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication Mon Nov 04 21:24:11 2013 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key Mon Nov 04 21:24:11 2013 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication Mon Nov 04 21:24:11 2013 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA Mon Nov 04 21:24:11 2013 [BlackCloud] Peer Connection Initiated with [AF_INET]146.185.165.114:1194 Mon Nov 04 21:24:12 2013 MANAGEMENT: >STATE:1383596652,GET_CONFIG,,, Mon Nov 04 21:24:13 2013 SENT CONTROL [BlackCloud]: 'PUSH_REQUEST' (status=1) Mon Nov 04 21:24:13 2013 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 8.8.8.8,dhcp-option DNS 8.8.4.4,route 10.8.0.1,topology net30,ping 5,ping-restart 30,ifconfig 10.8.0.6 10.8.0.5' Mon Nov 04 21:24:13 2013 OPTIONS IMPORT: timers and/or timeouts modified Mon Nov 04 21:24:13 2013 OPTIONS IMPORT: --ifconfig/up options modified Mon Nov 04 21:24:13 2013 OPTIONS IMPORT: route options modified Mon Nov 04 21:24:13 2013 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified Mon Nov 04 21:24:13 2013 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0 Mon Nov 04 21:24:13 2013 MANAGEMENT: >STATE:1383596653,ASSIGN_IP,,10.8.0.6, Mon Nov 04 21:24:13 2013 open_tun, tt->ipv6=0 Mon Nov 04 21:24:13 2013 TAP-WIN32 device [Connection to local network 2] opened: \\.\Global\{1F94FE76-56C7-43B1-8658-9EDE78233D8A}.tap Mon Nov 04 21:24:13 2013 TAP-Windows Driver Version 9.9 Mon Nov 04 21:24:13 2013 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.8.0.6/255.255.255.252 on interface {1F94FE76-56C7-43B1-8658-9EDE78233D8A} [DHCP-serv: 10.8.0.5, lease-time: 31536000] Mon Nov 04 21:24:13 2013 NOTE: FlushIpNetTable failed on interface [15] {1F94FE76-56C7-43B1-8658-9EDE78233D8A} (status=5) : Åtkomst nekad. Mon Nov 04 21:24:18 2013 TEST ROUTES: 2/2 succeeded len=1 ret=1 a=0 u/d=up Mon Nov 04 21:24:18 2013 C:\windows\system32\route.exe ADD 146.185.165.114 MASK 255.255.255.255 192.168.1.1 Mon Nov 04 21:24:18 2013 ROUTE: route addition failed using CreateIpForwardEntry: Denied Access. [status=5 if_index=13] Mon Nov 04 21:24:18 2013 Route addition via IPAPI failed [adaptive] Mon Nov 04 21:24:18 2013 Route addition fallback to route.exe Mon Nov 04 21:24:18 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem Mon Nov 04 21:24:18 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1 Mon Nov 04 21:24:18 2013 C:\windows\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.8.0.5 Mon Nov 04 21:24:18 2013 ROUTE: route addition failed using CreateIpForwardEntry: Denied Access. [status=5 if_index=15] Mon Nov 04 21:24:18 2013 Route addition via IPAPI failed [adaptive] Mon Nov 04 21:24:18 2013 Route addition fallback to route.exe Mon Nov 04 21:24:18 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem Mon Nov 04 21:24:18 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1 Mon Nov 04 21:24:18 2013 C:\windows\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.8.0.5 Mon Nov 04 21:24:18 2013 ROUTE: route addition failed using CreateIpForwardEntry: Denied Access. [status=5 if_index=15] Mon Nov 04 21:24:18 2013 Route addition via IPAPI failed [adaptive] Mon Nov 04 21:24:18 2013 Route addition fallback to route.exe Mon Nov 04 21:24:18 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem Mon Nov 04 21:24:18 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1 Mon Nov 04 21:24:18 2013 MANAGEMENT: >STATE:1383596658,ADD_ROUTES,,, Mon Nov 04 21:24:18 2013 C:\windows\system32\route.exe ADD 10.8.0.1 MASK 255.255.255.255 10.8.0.5 Mon Nov 04 21:24:18 2013 ROUTE: route addition failed using CreateIpForwardEntry: Denied Access. [status=5 if_index=15] Mon Nov 04 21:24:18 2013 Route addition via IPAPI failed [adaptive] Mon Nov 04 21:24:18 2013 Route addition fallback to route.exe Mon Nov 04 21:24:18 2013 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem Mon Nov 04 21:24:18 2013 ERROR: Windows route add command failed [adaptive]: returned error code 1 Mon Nov 04 21:24:18 2013 Initialization Sequence Completed Mon Nov 04 21:24:18 2013 MANAGEMENT: >STATE:1383596658,CONNECTED,SUCCESS,10.8.0.6,146.185.165.114 " Thanks in Advance
6 Answers
Well , show me the config in the server , and config in the client.

In the windows do you have installed the client of openvpn-gui ,and running with the permission of administrator click right in the Openvpn-GUI and select "Running Administrator".

It worked when i run the Openvpn-Gui as Admin. Thanks!
please can someon help with the server and client config for open vpn
i have configured one but when i tried to connect it keeps saying no server verification method
I have the same problem in my android. When I run Openvpn it connects to the server but I can't browse internet. I've tried forwarding port 443 on my modem but nothing happened.
Have another answer? Share your knowledge.