Operation Timeout - SSH connection on OS X 10.10

August 5, 2014 9.4k views

ssh root@128.199.244.xxx
ssh: connect to host 128.199.244.xxx port 22: Operation timed out

Cannot connect both at work and at home, any ideas


1 comment
6 Answers

Are you able to connect through the console in the DigitalOcean control panel? That error could mean anything from your droplet is not on to the SSH daemon isn't running. Have you set up any firewalling/IPtables rules? Port 22, which is needed to connect via SSH, could be closed.

Use the control panel to connect to the droplet. Once logged in, run sudo netstat -plunt In the output, you should see a line like:

tcp        0      0    *               LISTEN      803/sshd        

If not, then the SSH daemon isn't running. Try running sudo service ssh start If it does show up but you aren't able to connect, then the most likely issue is that your firewall is blocking the port.

I had a similar issue twice with two different droplets. Rebooting the server helped in both cases.

Login to your DigitalOcean dashboard and access the droplet via the Console Access. If you're able to login there, just enter the following command to reboot

sudo reboot

If you cannot login, then use the Power Cycle button instead.

Hope this helps someone :)

I had the same issue. I had to log in using VNC Connection, which upon login immediately prompts me to reset root password. After that I could connect using ssh without problem. Don't know whether it's related to my not using a SSH key to connect. Could be a procedure update on the side of Ubuntu? I suggest digitalocean revise their setup guide for Ubuntu 14.04.

I have the same problem.

It happened after changing some folder permissions for wp-content (WordPress) and adding an AllowUser wp-user to my sshdconfig. I since went into the console (still have access on that end) and removed the AllowUser line from my sshdconfig file, and have rebooted/power cycled a few times.

It would appear as though SSH is running, is there only suppose to be one instance of sshd running @asb? Because I appear to have two.

I should also add, I appear to have something funny going on with traceroute:
erfans-imac:~ erfanv$ traceroute
traceroute to (, 64 hops max, 52 byte packets
1 * * *
2 * * *
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *
8 * * *

Maybe I need some more reboots...

Well, I can SSH in now. Not sure what fixed it. I uninstalled and reinstalled OpenSSH, rebooted the machine several times, gave it some time, and tried accessing from another internet provider and it works now. Strange, because it WAS working on the internet/computer that I was originally working with, and then just stopped. Traceroute is giving back proper pings now.

Reboot doesn't help me but before that i had install whereami package. So i suspect and remove this package and reboot . It worked perfectly fine again.

Have another answer? Share your knowledge.