I’ve installed Perforce (p4d) and all it working fine. The thing I’m having trouble with is p4d -d running when the server reboots.
I’ve done the following:

sudo apt-get install daemon  
cd /etc/init.d  
wget https://raw.githubusercontent.com/Allar/linux-perforce-installer/master/p4dservice  
chmod +x p4dservice 
sudo update-rc.d p4dservice defaults 

The script seems to work although I get a “missing lsb information” warning (which I don’t think should effect anything.

The big issue is that on reboot, p4d does not start.
Can someone take a look at that script or maybe this whole process and let me know what I’m doing wrong?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello, @tommywright

You can use chkconfig to add script to start on boot using chkconfig with –add parameter

Another way will be to start with a cron job that will run on every minute, so once the server is booted, the cron will run and start the service.

Hope this helps.

Submit an Answer