Question

Package mariadb-server-5.5 is not configured yet

Hello;

i am having the following error on my ubuntu server whenever i run

apt-get update && apt-get upgrade

The following errors occur…

Setting up mariadb-server-5.5 (5.5.47+maria-1~trusty) ...
 * Stopping MariaDB database server mysqld                               [ OK ]
 * Starting MariaDB database server mysqld                               [fail]
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mariadb-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mariadb-server:
 mariadb-server depends on mariadb-server-5.5 (= 5.5.47+maria-1~trusty); however                                                                                        :
  Package mariadb-server-5.5 is not configured yet.

dpkg: error processing package mariadb-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup erro                                                                                        r from a previous failure.
                          Errors were encountered while processing:
 mariadb-server-5.5
 mariadb-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

It seems to be the result of a muddled setup between installing mariadb and mysql. Rebooting the machine and running apt-get again solved the issue for me.