password protected directory on VPS Ubuntu 14.04``

October 8, 2014 1.9k views

I just installed LAMP on ubuntu 14.04 and I have problem with password protected directory.

AuthName "Restricted Area" 
AuthType Basic 
AuthUserFile /home/marko/public_html/.htpasswd 
AuthGroupFile /dev/null 
require valid-user

This is my .htaccess file in root of my project.

I enabled and authzgroupfilemodule in apache and also apache2-utils is installed.

The problem is when I do drop in my site I can enter my username and password but on every post method I am getting 401 error. For example when I want to log in in my account this is happening, Project is done in php CI fw. Everything is fine when I disable folder protection.


This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

This is my config file of 000-default.conf

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /home/marko/public_html
        ErrorLog /home/marko/logs/error.log
        CustomLog /home/marko/logs/access.log combined
    <Directory />
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Require all granted
        Allow from all
        #Include conf-available/serve-cgi-bin.conf
What I can do more to get this to work?
1 comment
  • Your .htaccess and 000-default.conf look good and the fact that you are getting the 401 error would mean that authentication is enabled. Have you checked to ensure that your .htpasswd file is formatted properly? Re-creating the .htpasswd might be worth trying to see if it resolves the issue.

1 Answer


I just recreated .htpasswd with this command:
htpasswd -c .htpasswd my-username
And I still have a problem, anyother solution?


Have another answer? Share your knowledge.