Question

PasswordAuthentication resets to 'No' after creating a droplet from a snapshot that has this value as 'yes'

I’ve a snapshot that I have created from a droplet that has ssh key but I also want to be able to access it with a password so I set PasswordAuthentication to yes (inside /etc/ssh/sshd_config) and restarted ssh service (service sshd restart) before saving the snapshot. Now when I create other droplets using this snapshot and specify ssh key and then try to login with password I can not and when I logged in with ssh key to see whats wrong I noticed PasswordAuthentication was set back to ‘no’!! how can I force it to stay on the value I specified which was ‘yes’ ?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

create a bash script like below in /root/ directory for example:

#!/bin/bash
sudo sed -i "/^[^#]*PasswordAuthentication[[:space:]]no/c\PasswordAuthentication yes" /etc/ssh/sshd_config
sudo service sshd restart

Then create a systemd system(if using a systemd system like centos) to run this script on start up.

Did you ever figure out a solution to this? Kinda frustrating to spawn machines for a class and then have to go in and enable password logins again.