permalinks (arch + nginx + wordpress)

Posted June 7, 2013 5.1k views
Hi guys, I installed on my machine arch + nginx and I'm trying to run a wordpress site . It is installed in /srv/http/wordpress/ . I'm getting crazy with the nginx configuration. In order to work properly with wordpress and permalinks , you should change some config on nginX , so i did. I've created one specific wordpress.conf on sites-available/enabled and I'm including them on ngin.conf. Well the closest i got is the following: Now, the permlinks are working , but i have no freaking idea why every other link (css,js) are pointing to the index.php also) Someone to help me out a bit? any lights? I tried every configuration possible found on the net... Cheers,

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers
How did you do it? It sounds like you just redirected everything to the index.php instead of only non-existing directories and files. When I googled, I found which should do the job.
Presuming the rest of your setup is correct then nginx helper will make nginx play nicely with permalinks. Just turn off its nginx-cache-purge stuff if you aren't using it.