Permission problems in Wordpress (Lemp+Ubuntu 14.04+WP)

September 16, 2014 5k views

Hi all!

Thanks to the fantastic community that are here i managed to install LEMP in ubuntu 14.04 and Wordpress.

Everything perfect, until you i try to handle wordpress backend.
I can't install themes or plugin, if i try manually via sftp the theme don't show in wordpress menu and if i try to upload via wordpress i get a message: "FTP or SSH credentials to proceed.."

How can i free wordpress of permissions as when I was in apache for working comfortable ?

Thank you very much!!

3 Answers
by Justin Ellingwood
WordPress is the most popular content management system (CMS) on the web currently. While WordPress can be a great way to manage you content, there are some very insecure configurations that are given throughout the internet. This article will cover how to set up secure updates and installations using SSH keys instead of FTP, which is an inherently insecure protocol.

I tried installing Wordpress (on ubuntu 14) "in one click" and no problem when installing plugins or themes.

How I can get this in my custom installation with lemp without problems of permissions like the "one click application" version ?

Thanks again!!!

Have another answer? Share your knowledge.