Question

Phalcon extension info not showing in phpinfo()

Posted May 25, 2014 8.9k views
Hi all, Brand new to DO and getting my first server up and running - little by little... Have worked through the walk-through here (https://www.digitalocean.com/community/articles/how-to-install-and-get-started-with-phalcon-on-an-ubuntu-12-04-vps) for getting Phalcon set up. Looks OK, no errors. I've added extension=phalcon.so to the php.ini file and restarted Apache, but I'm not seeing a phalcon section in the output from phpinfo(). Can't think what I've missed. I'm guessing the library has been installed in a non-standard location? Any suggestions appreciated. Mark

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

8 answers

I have also encounter the same problem but unable to resolve it using these steps.

Just checked the php.ini file and the extension_dir is commented out... doh ..question is where would that be on my Ubuntu server?
phpinfo() tellls me the extensions are at /usr/lib/php5/20121212, which I've added to the ini. Still can't see phalcon.
Hmm.. looks like the path to the extensions directory is OK and the file phalcon.so is in there. Version mismatch somewhere?
Is there a specific place in the ini file I need to put the extension=phalcon.so entry. It's currently the last thing in the file.
SOLVED - the way extensions are referenced seems to have changed or be different on Ubuntu. I'n guessing the former. Found this on the Phalcon forum:

http://forum.phalconphp.com/discussion/2386/-solved-installing-on-ubuntu-14-04#C8113
Glad you figured it out Mark! Thanks for following up and leaving your solution for everyone else.

I have the same problem. I use LEMP on Ubuntu . I have tried all this steps but it doesn’t help.
Please any suggestions

Submit an Answer