Question

PHP 7.2 NOTICE on APACHE 2

Hi I normally do my upgrades without issue but today I get the following notice. Do I need to do anything about it?

NOTICE: Not enabling PHP 7.2 FPM by default.
NOTICE: To enable PHP 7.2 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.2-fpm
NOTICE: You are seeing this message because you have apache2 package installed.
Setting up php7.2-xml (7.2.6-1+ubuntu16.04.1+deb.sury.org+1) ...
Setting up php7.2-gd (7.2.6-1+ubuntu16.04.1+deb.sury.org+1) ...
Setting up libapache2-mod-php7.2 (7.2.6-1+ubuntu16.04.1+deb.sury.org+1) ...
libapache2-mod-php7.2: not switching MPM - already enabled
Setting up php7.2 (7.2.6-1+ubuntu16.04.1+deb.sury.org+1) ...
Processing triggers for php7.2-fpm (7.2.6-1+ubuntu16.04.1+deb.sury.org+1) ...
NOTICE: Not enabling PHP 7.2 FPM by default.
NOTICE: To enable PHP 7.2 FPM in Apache2 do:
NOTICE: a2enmod proxy_fcgi setenvif
NOTICE: a2enconf php7.2-fpm
NOTICE: You are seeing this message because you have apache2 package installed.

I am using nginx on ubuntu and php7.2 since a week or so. Thanks

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Thanks for the help. It turned into a mission to copy anything! Not got the headspace today…but thanks.

Hello,

It looks like you have both Mod PHP and PHP-FPM installed at the same time. Both are PHP handlers and you should choose one and disable the other.

I would recommend going for PHP-FPM as you would see a boost in the performance. Though it might require some additional changes in your Virtual Host.

Regards, Bobby