PHP cannot use Enviroment Variable, even though it appears to be set. How can I get PHP to notice it?

March 29, 2018 1.2k views
PHP Ubuntu 16.04

I have started using Sendgrid on my website to allow emails to sent to my users when they sign up for my site.

I copied the api call for Sendgrid into my site code and tried to send an email. I received a permission denied error. I contacted the Sendgrid support before making this post and have been working with them to try and fix this issue but we are stuck because it does not seem like PHP is picking up the environment variable that I have set to store my Sendgrid api key.

When I hard code in the key, I am able to send emails through Sendgrid with one issues, it is only when I attempt to have the api key called through an environment variable. Like this: `$apiKey = getenv('SENDGRID_API_KEY');

I am certain it is not being set because when I try to echo $apiKey in php, I do not get anything back.

First, I tried sourcing the environment variable though an env file like it states on the Sendgrid website.

echo "export SENDGRID_API_KEY='YOUR_API_KEY'" > sendgrid.env
echo "sendgrid.env" >> .gitignore
source ./sendgrid.env

When that didn't work, I followed this article on how to set environment variables on my droplet, but still does not seem to work. I still get a permission denied error from Sendgrid's api when making a call with the environment variable.

When I do printenv from my droplet's terminal, I can see the variable so I imagine it is set on my server but how to do I make it be seen by PHP?

1 Answer

Looks like this may be a security feature (stopping php from reading environment variables).

There may be a setting you have to turn on (or off) in php.ini but what I've found if you put the enviroment variable in /etc/enviroment php will read it with getenv().

This link may shed some light on it:
https://stackoverflow.com/questions/13568191/how-to-get-system-environment-variables-into-php-while-running-cli-apache2hand

Have another answer? Share your knowledge.