Hi, I installed on Ubuntu 14.04 Vesta (with, php, mysql, phpmyadmin etc).

On my website I use php imagettftext() function to write text on images.
Since years ago I used to write on other servers the font path like:

        $font = 'arialbd.ttf';

but here in Ubuntu with vesta and PHP Version 5.6.7-1 will get error: Could not find/open font in .......

I found 2 resolutions for my problem:

1.

        putenv('GDFONTPATH=' . realpath('.'));
        $font = 'arialbd.ttf';

2.

        $font = './arialbd.ttf';

How can I set to use only:

        $font = 'arialbd.ttf';

?

1 comment
  • I know that this was from 2015, but I still had to come back to thank you in 2020! I tried step “2.” and this solved my problem! Thanks Sebastian!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

This link should provide you the information you need to ensure you are setting the proper font path for GD.

Submit an Answer