Question

phpMyAdmin ignores 'config.inc.php'

  • Posted July 22, 2014

Hi,

I have Ubuntu 14.04 running Nginx, MySQL, PHP5, Ajenti and Ajenti V. I also installed phpMyAdmin and I can access it via <server>/phpmyadmin. But phpMyAdmin seems to ignore the config.inc.php file.

I say that the config file is “ignored” because phpMyAdmin actually works but doesn’t load my preferences (and keeps asking about the blowfish_secrect passphrase, for example).

I tried these different approches: created the file from scratch, duplicated and renamed config.inc.sample.php and used the phpMyAdmin setup utility. The result is the same.

The file is present, the permissions seem to be OK (-rw-r--r-- 1 root root) but phpMyAdmin doesn’t want to use it. :)

Anybody else ever encountered that?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

how did you install phpMyAdmin? If you do it via yum, then the config.inc.php is taken care of, but if it was manual, then you need to make sure config.inc.php is placed in the top-level directory of phpMyAdmin (e.g. /usr/share/phpMyAdmin). Permissions don’t seem to matter, as mine is root:root and still works.

Using phpmyadmin, on Debian Jessie 8, installed thru the official repository with apt-get. There is a config folder in /etc/phpmyadmin where the config.inc.php is situated. Editing /etc/phpmyadmin/config.inc.php worked for me.

in mycase this help

  1. chmod 644 /etc/phpMyAdmin/config.inc.php
  2. chmod 755 /etc/phpMyAdmin/

neuroticimbecile Hit this on the head. Mine was blank so I copied the contents of the sample file over edit my values then whala.

Try to edit this file instead: /var/lib/phpmyadmin/config.inc.php

I may have found a solution, it looks like it’s related to the website open_basedir setting in Ajenti V.

I had to manually install PHPMyAdmin and so that resulted in me having tons of config files everywhere (/usr/share/, /etc/phpmyadmin/, /var/lib/phpmyadmin)

PHPMyAdmin was looking for the config.inc.php file in /usr/share/phpmyadmin/ however, no file was present. Duplicated the config.sample.inc.php from that same directory, renamed it, and it worked like a charm.

I’m having the same issue with nginx, the config.inc.php it’s completely ignored.

I do go crazy with this. I just can’t change preferences on my last local debian phpmyadmin 4.2.12deb2+deb8u1 Tried do change config.inc.php owner, added a die(‘here’) in the file that shows that the file is actualy read. But the simple line

$cfg['PropertiesIconic'] = TRUE;

won’t work ! The preferences must be changed somewhere later

It has been quiet some time since this post was created but it’s always important to keep it up to date so it may help other users.

The reason phpMyAdmin ignores ‘config.inc.php’ is file ownership. make sure the ‘config.inc.php’ is owned by the appropriate user (apache or Nginx).

Have fun ;)