phpMyAdmin ignores ''

Posted July 22, 2014 40.6k views


I have Ubuntu 14.04 running Nginx, MySQL, PHP5, Ajenti and Ajenti V. I also installed phpMyAdmin and I can access it via <server>/phpmyadmin. But phpMyAdmin seems to ignore the file.

I say that the config file is “ignored” because phpMyAdmin actually works but doesn’t load my preferences (and keeps asking about the blowfish_secrect passphrase, for example).

I tried these different approches: created the file from scratch, duplicated and renamed and used the phpMyAdmin setup utility. The result is the same.

The file is present, the permissions seem to be OK (-rw-r--r-- 1 root root) but phpMyAdmin doesn’t want to use it. :)

Anybody else ever encountered that?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
10 answers

in mycase this help

  1. chmod 644 /etc/phpMyAdmin/
  2. chmod 755 /etc/phpMyAdmin/

how did you install phpMyAdmin? If you do it via yum, then the is taken care of, but if it was manual, then you need to make sure is placed in the top-level directory of phpMyAdmin (e.g. /usr/share/phpMyAdmin). Permissions don’t seem to matter, as mine is root:root and still works.

I may have found a solution, it looks like it’s related to the website open_basedir setting in Ajenti V.

  • Hello. I do not use Apache. I use a bunch of nginx + php-fpm + mariadb. I
    established myself PhpMyAdmin all set properly and I was able to go But there is one problem that the file is
    /etc/phpMyAdmin/ completely ignore. I even deleted it but
    continues to work PhpMyAdmin. It is necessary to configure PhpMyAdmin, but
    the system did not see /etc/phpMyAdmin/ How to make so that would take into account the settings in the file /etc/phpMyAdmin/

  • I’m having the exact same issue for the last 2 days and it has been doing my heading…

    I have been scanning the internet for hours and I simply cannot find any fix to this.

Try to edit this file instead: /var/lib/phpmyadmin/

neuroticimbecile Hit this on the head. Mine was blank so I copied the contents of the sample file over edit my values then whala.

Using phpmyadmin, on Debian Jessie 8, installed thru the official repository with apt-get.
There is a config folder in /etc/phpmyadmin where the is situated.
Editing /etc/phpmyadmin/ worked for me.

I had to manually install PHPMyAdmin and so that resulted in me having tons of config files everywhere (/usr/share/, /etc/phpmyadmin/, /var/lib/phpmyadmin)

PHPMyAdmin was looking for the file in /usr/share/phpmyadmin/ however, no file was present. Duplicated the from that same directory, renamed it, and it worked like a charm.

It has been quiet some time since this post was created but it’s always important to keep it up to date so it may help other users.

The reason phpMyAdmin ignores ‘’ is file ownership. make sure the '’ is owned by the appropriate user (apache or Nginx).

Have fun ;)

I do go crazy with this. I just can’t change preferences on my last local debian phpmyadmin 4.2.12deb2+deb8u1
Tried do change owner, added a die(‘here’) in the file that shows that the file is actualy read. But the simple line

$cfg['PropertiesIconic'] = TRUE;

won’t work !
The preferences must be changed somewhere later

I’m having the same issue with nginx, the it’s completely ignored.