phpMyAdmin installation on CentOS 6.5 allows log in, but returns a blank page.

July 21, 2014 3.2k views

I've managed to install phpMyAdmin after massive effort, and I can get a log in prompt when I access <ipaddress>/phpmyadmin/

I followed this tutorial on how to install phpmyadmin on CentOS 6.4 (I'm using 6.5).

After I log in, however, it gave me first a 2 panel page with a Forbidden. You do not have access to phpmyadmin/navigation.php and Forbidden. You do not have access to phpmyadmin/main.php Now it's just showing a blank page - but the favicon shows at the top.

I'm using Chrome browser to access in case that's relevant. I have restarted httpd each time.

I can access phpmyadmin/Documentation.html OK but no PHP files it seems. I've tried changing permissions on the /usr/share/phpMyAdmin/ and its content, but that does nothing (they're now back at 644 and all owned by root).

BTW friends, double- & triple- check your IP address if you're changing the config file to limit access. The 3 IP address checkers each gave me a *different** one - the last one finally worked.
*
This seems much more painful that it should be! What am I missing? (I promise to let you know what works as well - drives me nuts to see posts saying 'it's fixed now' without saying how!!)

Thanks in advance.

3 Answers

It looks like there's a php error, which usually results in a white page. Check Apache's error log, are there any errors?

sudo tail /var/log/httpd/error_log

Hi Kamal, Thanks for your response. Output of log file from last two reboots below. I can't see anything wrong here - and I think Apache error verbosity is at its highest.

Any other suggestions?

Justin

sudo tail /var/log/httpd/errorlog
[Mon Jul 21 10:13:21 2014] [notice] caught SIGTERM, shutting down
[Mon Jul 21 10:13:22 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jul 21 10:13:22 2014] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 21 10:13:22 2014] [notice] Digest: done
[Mon Jul 21 10:13:22 2014] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.5.14 mod
ssl/2.2.15 OpenSSL/1.0.1e-fips configured -- resuming normal operations
[Mon Jul 21 20:48:39 2014] [notice] caught SIGTERM, shutting down
[Mon Jul 21 20:48:40 2014] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jul 21 20:48:40 2014] [notice] Digest: generating secret for digest authentication ...
[Mon Jul 21 20:48:40 2014] [notice] Digest: done
[Mon Jul 21 20:48:40 2014] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.5.14 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips configured -- resuming normal operations

  • Forgot to mention that I can see the results of a phpinfo.php file - I presume that shows some PHP is working?

  • Also wondering why, if I've created a droplet in the Singapore data centre, my server timestamp is US EST? We're 12 hours ahead, but I digress...

Still getting a blank page.
Things I have tried so far:

  • set the server time to the correct timezone and time (no effect, except now have correct time)
  • checked that I'm not missing any symlinks (php config seems to be working OK)
  • checked permissions (644) user (apache) and group (apache)
  • checked log and access files for apache (just says that the page was requested) - I set LogLevel in httpd.conf to 'debug'

Is it possible it's something to do with SELinux?

  • I'm not sure, but it's possible. Try disabling SELinux temporarily: (as root)

    setenforce Permissive
    

    Does that fix it?

Have another answer? Share your knowledge.