Question

Phpmyadmin is not securing (with http auth)

Hey, I had followed all steps from below article to secure (auth) phpmyadmin, but it now showing auth popup. https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-on-ubuntu-16-04

Same steps working for my beta domain on separate droplet, while for live its not working, live is on separate high config droplet. I also had compare beta and live files for auth functionality but all are identical, still live phpmyadmin is not securing by auth (while beta domain is secure by auth)

Below are my config files and code,

/etc/apache2/conf-available/phpmyadmin.conf

<Directory /usr/share/phpmyadmin>
    Options FollowSymLinks
    DirectoryIndex index.php
    AllowOverride All
</Directory>

/usr/share/phpmyadmin/.htaccess

AuthType Basic
AuthName "Restricted Files"
AuthUserFile /etc/phpmyadmin/.htpasswd
Require valid-user

/etc/phpmyadmin/.htpasswd MyPass:$apr3435/iI$33%DSMK7K//cdfff5ncy.YZh1

I also had restart apache (also restarted droplet), but its not working.

Do anyone had idea what could be the wrong/misconfigured?

Thanks.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @kirandev:

Just got the answer, I had copy phpmyadmin.conf cp conf-available/phpmyadmin.conf conf-enabled/phpmyadmin.conf (and ofcourse restart apache)

View the original comment