PHPMyAdmin MySQL/Nginx/Ubuntu 18.04 Install Error


I am trying to install phpmyadmin on my Ubuntu 18.04/Nginx Server.

Because digital ocean does not yet have a guide for 18.04/Nginx/PHPMyAdmin yet I was using this one:

But after I follow all the steps I get the error below.

How can I fix this?

An error occurred while installing the database: 

mysql said: ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IDENTIFIED BY '********'' at line 1 . Your options are:
    * abort - Causes the operation to fail; you will need to downgrade,
      reinstall, reconfigure this package, or otherwise manually intervene
      to continue using it. This will usually also impact your ability to
      install other packages until the installation failure is resolved.
    * retry - Prompts once more with all the configuration questions
      (including ones you may have missed due to the debconf priority
      setting) and makes another attempt at performing the operation.
    * retry (skip questions) - Immediately attempts the operation again,
      skipping all questions. This is normally useful only if you have
      solved the underlying problem since the time the error occurred.
    * ignore - Continues the operation ignoring dbconfig-common errors.
      This will usually leave this package without a functional database.

   Next step for database installation:

                                                        retry (skip questions) 


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

If you already install mysql on your server, there is a simple way to install phpmyadmin on your server folder. Steps to follow,

  1. Go to
  2. Copy the link of file you want to install
  3. Go to terminal and type "wget link ". eg: “wget
  4. Unzip the archieve
  5. Rename the folder
  6. Access the folder via web browser and you are ready to go

i really struggled with this issue while setting up a server on Digital Ocean. I needed a server to Host a Laravel application. Basically i had to setup my server by installing Nginx using this Tutorial, then i installed MYSQL Version 8.0.22 using this Tutorial (basically the latest available version - Which usually leads to this error), then i installed PHP7.4 using this Tutorial of which also required me to check the DigitalOcean article to configure the php processor for Nginx using the same Tutorial i used to install Nginx.

At this point i wanted to install phpMyAdmin, and it failed with the same error, i read every article i could find on Digital Ocean, Stackoverflow and other forums and no solution worked. I found out i could download phpMyAdmin version 5.0.4 or greater (Basically the latest version) from the official website since it would be more compatible with the MYSQL Version 8.0.22. I followed this Tutorial exactly to install phpMyAdmin manually instead of automatically and everything worked perfectly! I was able to open the phpMyAdmin on the browser and even able to login using root and password. I created another user as indicated on the tutorial and was also able the login using that new user.

Really hope this helps someone having the same issue. In conclusion use this article to install phpMyAdmin manually: