Question

PhpMyAdmin not working Plesk Centos 7 installation

I have created a droptlet with Plesk and Centos 7 installation on vps and tried to open phpMyAdmin that came with Plesk but I get the issue.

Error during session start; please check your PHP and/or webserver log file and configure your PHP installation properly. Also ensure that cookies are enabled in your browser.

session_start(): open(SESSION_FILE, O_RDWR) failed: No such file or directory (2)

session_start(): Failed to read session data: files (path: @@PMA_TEMP_DIR@@/session)

I have tried changing the session directory to writable directory /tmp as I have searched for the solution but its not working as well.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @fnaseer4,

Check your php.ini file and where exactly are the sessiones being stored. The exact line in your php.ini file would be

session.save_path = "/path/to/session"

Check the permissions on the mentioned folder and if needed change them so that it’s able to write files in it.

If you are not sure where the php.ini file is, you can create an info.php file and add the following in it

<?php phpinfo(); ?>

and open it in your browser. It will display all your php settings right away.

Kind regards, Kalin