Question

phpmyadmin will not install on CentOS 7. Dependency errors.

I’m trying to install phpmyadmin on CentOS 7 using this guide – https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-with-nginx-on-a-centos-7-server, but it is not working. When I run:

yum install phpmyadmin

I get the following dependency errors:

–> Finished Dependency Resolution Error: Package: php-tcpdf-6.1.1-1.el6.noarch (epel) Requires: php-tidy Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel) Requires: php(api) = 20090626 Installed: php-common-5.4.16-23.el7_0.3.x86_64 (@updates) php(api) = 20100412-64 Available: php-common-5.4.16-21.el7.x86_64 (base) php(api) = 20100412-64 Available: php-common-5.4.16-23.el7_0.x86_64 (updates) php(api) = 20100412-64 Available: php-common-5.4.16-23.el7_0.1.x86_64 (updates) php(api) = 20100412-64 Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel) Requires: php(zend-abi) = 20090626 Installed: php-common-5.4.16-23.el7_0.3.x86_64 (@updates) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-21.el7.x86_64 (base) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-23.el7_0.x86_64 (updates) php(zend-abi) = 20100525-64 Available: php-common-5.4.16-23.el7_0.1.x86_64 (updates) php(zend-abi) = 20100525-64 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

If I try to install the dependencies, such as php-tidy and php-mcrypt, I get more errors:

yum install php-tidy “No package php-tidy available”

yum install php-mcrypt Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel) Requires: php(api) = 20090626 Installed: php-common-5.4.16-23.el7_0.3.x86_64 (@updates) php(api) = 20100412-64

yum install php Package php-5.4.16-23.el7_0.3.x86_64 already installed and latest version Nothing to do

Any ideas?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Try this:

yum --enablerepo=remi,remi-php56 install phpmyadmin

This should install with all the dependencies.

I’d recommend the CentOS plugin protectbase this plugin will help when dealing with multiple 3rd party repos or just EPEL/RPMForge

You can use “yum --disablerepo=[reponame] …” but that’s a single use option if you’d like to protect your system continuously then I’d highly recommend the “protectbase”

“yum install yum-plugins-protectbase”

Then add “protect=1” on the repos you’d want to protect. Aka CentOS-Base And add “protect=0” to epel.repo this should solve most common conflicts when dealing with 3rd party repositories.

I created a more in-depth guide on my blog here Dealing with multiple repositories on CentOS 4/5/6/7

yum --enablerepo=remi,remi-php56 install php-mcrypt yum --enablerepo=remi,remi-php56 update yum update Try this and tell me it worked or not