Question

PM2 command not found

I am installing PM2 for hubot rocket.chat adapter. so i did the following: I firstly added a <pm2.json> file to hubot adapter folder, then sudo npm install pm2 -g cd <hubot directory> pm2 start <pm2.json>

The i got error saying this:

No command 'pm2' found, did you mean:
 Command 'wm2' from package 'wm2' (universe)
 Command 'pms' from package 'pms' (universe)
 Command 'pmk' from package 'pmk' (universe)
 Command 'pmw' from package 'pmw' (universe)
 Command 'fpm2' from package 'fpm2' (universe)
 Command 'pom2' from package 'libpod-pom-perl' (universe)
 Command 'pmi' from package 'powermanagement-interface' (universe)
 Command 'pm' from package 'powerman' (universe)
pm2: command not found

Then I tried to add the path by doing: sudo env PATH=$PATH:/home/jy/.npm-global/bin pm2 startup -u safeuser and export PATH=$PATH:/home/jy/.npm-global/bin and restarted PuTTY,

still get the same error.

when I went to where PM2 is at, which is /home/jy/.npm-global/bin, and do pm2 start <pm2.json> command, still get the same error.

Is there anything i did wrong? or there might be other reasons?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello,

Just came across this question. I could suggest that when installing pm2, make sure to add the -g flag:

sudo npm install pm2@latest -g

The -g option tells npm to install the module globally, so that it’s available system-wide.

Also, as a side note here is also a quick video on how to deploy Node.js with PM2, Nginx as a reverse proxy, and Cloudflare for SSL termination:

Best, Bobby

puma@puma:~$ echo $PATH /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/opt/puppetlabs/bin:/opt/node/lib/node_modules/pm2/bin:prefix/bin puma@puma:~$ pm2 list

Command ‘pm2’ not found, did you mean:

command ‘pom2’ from deb libpod-pom-perl command ‘wm2’ from deb wm2 command ‘pmc’ from deb linuxptp command ‘pmw’ from deb pmw command ‘pms’ from deb pms command ‘pm’ from deb powerman command ‘pmi’ from deb powermanagement-interface

Try: sudo apt install <deb name>

this is what i v got after doing your steps it’s the same thing as before

This comment has been deleted

Did you tried executing it as root?

  1. sudo pm2 status

Maybe you can try installing it as non-root user (your current user if you don’t use root). For that you need to enable global installing for non-root users by fixing permissions. There is Fix permissions tutorial on NPM docs page which should help you with it