Question

Port 3000 is closed and not listening

I installed plesk on ubuntu, my project works with port 3000 and other ports which needs to be enabled and also listens, but i am finding it difficult to find out how to really open it and get it to listen. Here is what i have tried:

  1. Using sudo ufw allow 3000 directly from ssh

  2. Enabling firewall and allowing on ports on plesk

  3. Using iptables to add ports. ( When i type in iptables list, it shows that the ports i added are there but when i type in the listening ports, my added ports isn’t included)

My ports are currently added but how do i get them to listen or is there something i’m not doing right?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @MacArthur,

You’ve mentioned that your project works on port 3000, make sure the project is working and actually listening to that port when checking. You can check what is listening on what ports using :

  1. netstat -tulepn

Additionally, how have you enabled the ports on Plesk? Plesk is quite needy and specific for such things. One other thing, I think Plesk comes with it’s own installation of a Firewall, is it UFW or something different?

Hello there,

I believe that with Plesk you’ll need to make sure that the ports are also open in Plesk Firewall too. If UFW is enabled then open the port using the command you’ve provided, also you can check our tutorial on how to set up a firewall with UFW

https://www.digitalocean.com/community/tutorials/how-to-set-up-a-firewall-with-ufw-on-ubuntu-20-0

Is there a particular service that you want to listen to on that port?

Hope that this helps!