Port 80 failed: Connection refused

Suddenly my server down !, and when tried curl http://myip -v

* Rebuilt URL to: http://myip/
*   Trying myip...
* connect to myip port 80 failed: Connection refused
* Failed to connect to myip port 80: Connection refused
* Closing connection 0
curl: (7) Failed to connect to myip port 80: Connection refused

How detect the reason ? which log file can i see it ?

Please help.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Nobody helped him, and I have the same problem. This doesn’t seem very straightforward. I have tried adding port forwarding, but no luck. I wonder if most of what you find is outdated…also, please stop telling people to “Google” when Google is exactly what brought me here.

Despite ufw or any other firewall rules on the Linux system. There are Firewalls rules in the DigitalOcean “Networking” panel. By default, there’s no 80 rule. You need to add HTTP/HTTPS to the firewall rules.

  • On DigitalOcean Control Panel page,
  • Open “Droplets”, select the droplet used
  • Go to “Networking” and check “Firewalls”, make sure there’s a rule: HTTP, TCP, 80, All IPv4 | All IPv6
  • If not, click the firewall group icon (the blue one above)
  • Under “Inbound Rules”
  • Add “New rule” and select HTTP (and HTTPS if needed)
  • Save and the 80 port should be accessible.

Hope this is helpful.

Hi there,

Just came across this question, this could mean that your web server is not running.

I could suggest starting with the following steps on how to troubleshoot common Nginx problems on a Linux server:

If you are using Apache you could follow the steps here:

Regards, Bobby

I have the same issue - no firewalls are set up, ufw is inactive, and all traffic to port 80 is refused though there is a server listening on it.

sudo netstat -nlp


tcp        0      0    *               LISTEN      19843/nginx -g daem

I can successfully curl the ip address or localhost from the droplet, but from anywhere else the connection is refused. Any server on port 80 will yield the same result, not just an nginx one - and any other port (81, 9000, etc) will work

The droplet version is 16.04.4

Hi. Its real trouble. I start Nginx on Ubuntu. Uwf is disabled. I use a command “telnet IP 80” to checking server. When I check it a local or from my other droplet all is ok. But if I try to connect with 80 port from my local machine this port is silenced. And when I’am restarting my Nginx on 8080. It works correctly!!!

Hey, DigitalOcean’s Devs, fix it, please, ASAP!!! %)

Check firewall, incase you had disabled for whatever reason and you did a droplet restart it might have come on. Run systemctl stop firewalld , to stop firewalld

For anyone having an issue of network connectivity I had to re-enable my firewall with

ufw enable

For whatever reason I think DigitalOcean reset it. Took me two hours. How unprofessional of this company


vim /etc/httpd/conf/httpd.conf Listen 88


I was having the same issue. I was getting Connection Refused error when trying to access the site using I was able to browse the site by setting any port other than 80 in nginx server listen module. I checked with 81, 2000 and few more- was accessible was accessible …

I found a solution of it after many hours-

I was missing Reset IPTables firewall rules. I used this link and did as mentioned.

My issue got fixed.

I posted this answer because may be it could help someone in same situation like mine.


Everything was working fine and suddenly this issue appeared +1. I can’t find what’s wrong 😢

I think it might be some issue with Digital Ocean service. After this reply for several minutes, all connections worked again, I didn’t make any changes on my server.