port is open in my droplet, blocked elsewhere

May 12, 2014 3.9k views
I'm trying to open up a port for minecraft (running on a server that shares a personal website that doesn't get much traffic) -- I've opened the port in the droplet but when I check the port from the web I can't reach it. I've googled to try and find out how to go about and resolve this on my own but the only thing I see is "open a ticket"
2 Answers
Of course I tried one last thing before I was finished and fixed it.

I initially used the command line to add rules to iptables, then tried using UFW ... I used netstat and it indicated things were open and fine ... but I still had issues...

I disabled ufw
`ufw disable`

I then configured to open the port for the default firewall service (`iptables-persistent`) by editing /etc/iptables/rules.v4 adding the line (for default minecraft server)

`-A INPUT -p tcp -m tcp --dport 25565 -j ACCEPT`

I reloaded the iptables service
`sudo service iptables-persistent restart`

and voilá.

I had same issue running for a few days, I found digitalocean blocked the ports for mail and mandrill because I has an issue of spam 3 months before (fxed that same day). Check if that the case, they never sent any message when they did it and they are not helping to fix it either. Hope you have more luck

Have another answer? Share your knowledge.