Hello.

I have followed the Wordpress one click install and everything went fine. I have a form with WP Forms in my website which notifies, sending a mail, my email address each time somebody fills the form.
Unfortunately, the email gets bounced back with the error invalid HELO name. This is what the mail log shows:

Jan 29 19:42:46 wo2 postfix/pickup[17325]: 3E83541287: uid=33 from=<www-data>
Jan 29 19:42:46 wo2 postfix/cleanup[17701]: 3E83541287: message-id=4a51c377698b2ba4a3cc557e5af14557@recconsulting-services.com
Jan 29 19:42:46 wo2 postfix/qmgr[1148]: 3E83541287: from=www-data@WordPress0ea3ddjkns20181213de454b, size=11780, nrcpt=1 (queue active)
Jan 29 19:42:52 wo2 postfix/smtp[17703]: 3E83541287: to=info@recconsulting-services.com, relay=mail.recconsulting-services.com[192.185.225.17]:25, delay=5.8, delays=0.02/0.01/5.6/0.17, dsn=5.0.0, status=bounced (host mail.recconsulting-services.com[192.185.225.17] said: 550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1) (in reply to MAIL FROM command))
Jan 29 19:42:52 wo2 postfix/cleanup[17701]: 1405943880: message-id=20190129194252.1405943880@WordPress0ea3ddjkns20181213de454b
Jan 29 19:42:52 wo2 postfix/qmgr[1148]: 1405943880: from=<>, size=14148, nrcpt=1 (queue active)
Jan 29 19:42:52 wo2 postfix/bounce[17704]: 3E83541287: sender non-delivery notification: 1405943880
Jan 29 19:42:52 wo2 postfix/qmgr[1148]: 3E83541287: removed
Jan 29 19:42:52 wo2 postfix/local[17706]: 1405943880: to=www-data@WordPress0ea3ddjkns20181213de454b, relay=local, delay=0.01, delays=0/0.01/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
Jan 29 19:42:52 wo2 postfix/qmgr[1148]: 1405943880: removed

this is my Postfix main.cf main parameters:

mydestination = $myhostname, localhost
myhostname = localhost

I have to specify that the emails are handled on another server, Hostgator. they normally arrive and are sent (so DNS is right) but the problem is just for sending emails to my own domain.

Please let me know if you need additional details.

Enrico.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

I hope this one is already fixed, but still I would like to shed some light on the error message itself.

A “550 Access Denied – Invalid HELO name” SMTP error usually occurs when the SMTP Domain configured as part of an email sender’s identity does not match the senders email address.

I usually use sendEmail with Postfix to send mails, this is something you can try as well.

Let me know if you have any questions.

Submit an Answer