Postfix error loop every two minutes

January 27, 2014 2k views
Hi, I've been configuring postfix and have done some successful testing, but messed up somehow with a test email. Below are five lines from a looping entry in /var/log/mail.log that are repeating every two minutes. I have stopped postfix for an hour and restarted. I've used 'ps aux' to identify and kill every postfix process. I've emptied the queue with 'postsuper -d ALL'. Whatever is happening here, I cannot find a way to kill it, and it has been going on for two days. Any ideas? Thanks in advance! Jan 27 00:52:15 localhost postfix/smtpd[4450]: connect from mydomain.org[] Jan 27 00:52:15 localhost postfix/smtpd[4450]: NOQUEUE: reject_warning: RCPT from mydomain.org[]: 504 5.5.2 : Helo command rejected: need fully-qualified hostname; from= to= proto=SMTP helo= Jan 27 00:52:15 localhost postfix/smtpd[4450]: NOQUEUE: reject: RCPT from kampot.org[]: 554 5.7.1 : Relay access denied; from= to= proto=SMTP helo= Jan 27 00:52:15 localhost postfix/smtpd[4450]: lost connection after RCPT from mydomain.org[] Jan 27 00:52:15 localhost postfix/smtpd[4450]: disconnect from mydomain.org[]
5 Answers
By the way, the email address did not appear in the error log lines as posted above. The to and from addresses are identical, and both are to an address at gmail.com ... relay access is working now with other tests, but this particular error does not go away.
I cannot resolve this problem and when I open a support ticket an automated reply told me to bring the matter up here. Can someone please help?
Can anyone suggest where else I can get support / help with this issue? The error is repeating 720 times a day. Digital Ocean support does not respond only to send an automated email suggesting to post to this community, and there has been no support through the community pages. Are there other places to go to find customer support ? I have searched the Internet for two days trying to find a solution. Is there anyone who works with digitalocean who can at least acknowledge that they have read this request? Please?
Some approaches I've tried:

# reconfigure postfix
dpkg-reconfigure postfix

# check postfix configuration
postconf -n

# verify DNS mail host setup
host mail.domain.org

# verify reverse DNS mail host setup

# delete postfix queues
postsuper -d ALL

# postfix debuggin info

# run postconf -n

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = all
mailbox_size_limit = 0
mydestination = $myhostname, localhost, localhost.localdomain, localhost
myhostname = domain.org
mynetworks = [::ffff:]/104 [::1]/128
myorigin = /etc/mailname
queue_directory = /var/spool/postfix
readme_directory = no
recipient_delimiter = +
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_delay_reject = yes
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks, warn_if_reject, reject_non_fqdn_hostname, reject_invalid_hostname, permit
smtpd_recipient_restrictions = reject_unauth_pipelining, reject_non_fqdn_recipient, reject_unknown_recipient_domain, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_rbl_client relays.ordb.org, reject_rbl_client sbl-xbl.spamhaus.org, permit
smtpd_sender_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_sender, reject_unknown_sender_domain, permit
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache

This page looks good:

But this hopeful tidbit of advice didn't work:

Soft bounce decreases the chances of endless bounce loops caused by an invalid email setup.

To enable soft bouncing, add this to your main.cf:

soft_bounce = yes

Have another answer? Share your knowledge.