Question

Postfix is not starting on server boot-CentOS

  • Posted July 23, 2014

Hello, I am getting the following error for Postfix service on server start “This service is dead. Start and stop postfix”. How can I resolve? I would like postfix to start automatically on reboot. Current config for postfix is 0: off 1: off 2: on 3: on 4: on 5: on 6: off

Subscribe
Share

I am facing the same problem… but the error is –

postfix: error while loading shared libraries: libssl.so.10: wrong ELF class: ELFCLASS32

As I am very new to centOS. Please help me resolving this…


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Check iSElinux by command $sestatus if SELinux status: enabled then: $restorecon -v -R /var/spool/postfix restorecon reset /var/spool/postfix/pid/unix.cleanup context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_var_run_t:s0 restorecon reset /var/spool/postfix/pid/unix.local context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_var_run_t:s0 restorecon reset /var/spool/postfix/pid/inet.smtp context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_var_run_t:s0 restorecon reset /var/spool/postfix/private/tlsmgr context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/rewrite context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/bounce context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/defer context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/trace context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/verify context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/proxymap context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/proxywrite context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/smtp context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/relay context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/error context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/retry context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/discard context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/local context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/virtual context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/lmtp context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/anvil context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/private/scache context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_private_t:s0 restorecon reset /var/spool/postfix/public/pickup context system_u:object_r:postfix_spool_t:s0->system_u:object_r:postfix_public_t:s0 restorecon reset /var/spool/postfix/public/cleanup context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_public_t:s0 restorecon reset /var/spool/postfix/public/qmgr context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_public_t:s0 restorecon reset /var/spool/postfix/public/flush context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_public_t:s0 restorecon reset /var/spool/postfix/public/showq context system_u:object_r:unlabeled_t:s0->system_u:object_r:postfix_public_t:s0 [root@lichsu ~]# systemctl start postfix

i have fixed my problem from 2 docs here: https://linuxize.com/post/how-to-disable-selinux-on-centos-7/ https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=781776

I see the following in the mail.log however, when I check permissions on the directories postfix is the owner. I also ran set-permissions postfix with no luck

Jul 23 14:43:58 localhost postfix/postfix-script[1895]: warning: not owned by postfix: /var/spool/postfix/private/defer Jul 23 14:43:58 localhost postfix/postfix-script[1896]: warning: not owned by postfix: /var/spool/postfix/private/proxywrite Jul 23 14:43:58 localhost postfix/postfix-script[1897]: warning: not owned by postfix: /var/spool/postfix/private/smtp Jul 23 14:43:58 localhost postfix/postfix-script[1898]: warning: not owned by postfix: /var/spool/postfix/private/local Jul 23 14:43:58 localhost postfix/postfix-script[1899]: warning: not owned by postfix: /var/spool/postfix/private/verify Jul 23 14:43:58 localhost postfix/postfix-script[1900]: warning: not owned by postfix: /var/spool/postfix/private/lmtp Jul 23 14:43:58 localhost postfix/postfix-script[1901]: warning: not owned by postfix: /var/spool/postfix/private/relay Jul 23 14:43:58 localhost postfix/postfix-script[1902]: warning: not owned by postfix: /var/spool/postfix/private/anvil Jul 23 14:43:58 localhost postfix/postfix-script[1903]: warning: not owned by postfix: /var/spool/postfix/private/proxymap Jul 23 14:43:58 localhost postfix/postfix-script[1904]: warning: not owned by postfix: /var/spool/postfix/private/tlsmgr Jul 23 14:43:58 localhost postfix/postfix-script[1905]: warning: not owned by postfix: /var/spool/postfix/private/error Jul 23 14:43:58 localhost postfix/postfix-script[1906]: warning: not owned by postfix: /var/spool/postfix/private/bounce Jul 23 14:43:58 localhost postfix/postfix-script[1907]: warning: not owned by postfix: /var/spool/postfix/private/discard Jul 23 14:43:58 localhost postfix/postfix-script[1908]: warning: not owned by postfix: /var/spool/postfix/private/trace Jul 23 14:43:58 localhost postfix/postfix-script[1909]: warning: not owned by postfix: /var/spool/postfix/private/rewrite Jul 23 14:43:58 localhost postfix/postfix-script[1910]: warning: not owned by postfix: /var/spool/postfix/private/virtual Jul 23 14:43:58 localhost postfix/postfix-script[1911]: warning: not owned by postfix: /var/spool/postfix/private/scache Jul 23 14:43:58 localhost postfix/postfix-script[1912]: warning: not owned by postfix: /var/spool/postfix/private/retry Jul 23 14:43:58 localhost postfix/postfix-script[1913]: warning: not owned by postfix: /var/spool/postfix/public/pickup Jul 23 14:43:58 localhost postfix/postfix-script[1914]: warning: not owned by postfix: /var/spool/postfix/public/cleanup Jul 23 14:43:58 localhost postfix/postfix-script[1915]: warning: not owned by postfix: /var/spool/postfix/public/showq Jul 23 14:43:58 localhost postfix/postfix-script[1916]: warning: not owned by postfix: /var/spool/postfix/public/qmgr Jul 23 14:43:58 localhost postfix/postfix-script[1917]: warning: not owned by postfix: /var/spool/postfix/public/flush Jul 23 14:43:58 localhost postfix/postfix-script[1926]: starting the Postfix mail system Jul 23 14:43:58 localhost postfix/master[1927]: fatal: fifo_listen: remove public/pickup: Permission denied

Thank you for your reply. Tried running chkconfig postfix on w/ no luck. Service starts fine manually postfix start and all works well. I am just not having any luck getting it to start on server start.

Normally to enable postfix to start on boot on CentOS, you would run:

chkconfig postfix on

Though it sounds like you might be running into some other type of issue. Are you seeing any error messages when you try to start postfix manually with service postfix start?