Question

Postfix not sending emails

Posted November 21, 2013 7.6k views
Hi everyone, I recently created a droplet with Ubuntu 12.04 and zpanel. I have dovecot and postfix working fine for webmail (roundcube). It sends and receives emails. I'm trying to use thunderbird to manage my email accounts but I can't send emails through it, only receive. SMTP por is 25. Ps: I can't telnet mydomain.com 25 from remote I can telnet localhost 25 from ssh I can telnet 127.0.0.0.1 25 from ssh Here's my /etc/zpanel/configs/postfix/main.cf http://pastebin.com/xLAde0uX a netstat -tupnl will show http://tinypic.com/r/kc14k0/5 my iptables are empty. I don't have any MX record registered on DO's DNS Manager. Any ideas?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers
You're more likely to find people that know how to use zPanel in the zPanel Forums. The zPanel docs might also be a good place to look.

With that said, I wonder if zPanel is blocking access to Port 25 from the outside world b/c Port 25 is not secure. Have you tried the TLS/SSL SMTP port, instead?
I will give it a try on zPanel forums. It was working until yesterday. Not sure what I changed in the files that made it stop working.
I will try to enable the other ports to see if that solves the issue. Thanks Pablo
opening port 567 solved the problem. I followed this tutorial: http://forums.zpanelcp.com/thread-9231.html?highlight=postfix
Submit an Answer