Question

postfix/smtp Connection timed out

  • Posted February 5, 2016
  • Email

Hello, I’m really frustrated.

I have a site running in a Centos 7 using php5.6, php-fpm and percona…

For some reason I can’t send emails from this server. I have another site running in a another server with same specs and it works without any problem.

Now I’m testing using the most basic command I know:

echo "My message" | /usr/sbin/sendmail user@emaildomain.com

and when I check the maillog I see:

Feb  5 14:17:52 stilo postfix/pickup[8508]: 8FB533FDAE: uid=0 from=<root>
Feb  5 14:17:52 stilo postfix/cleanup[32174]: 8FB533FDAE: message-id=<20160205191752.8FB533FDAE@stilo.localdomain>
Feb  5 14:17:52 stilo postfix/qmgr[8509]: 8FB533FDAE: from=<root@stilo.localdomain>, size=267, nrcpt=1 (queue active)
Feb  5 14:18:22 stilo postfix/smtp[32176]: connect to mx2.hotmail.com[65.55.92.136]:25: Connection timed out

I have tested it sending to different email providers and I got the same error.

I have check my /etc/postfix/main.cf side by side with the other server and they have the same configs.

Any clue of what could be wrong???

Subscribe
Share

@danielmiclos - So you used ‘postconf -n’ on both machines and did a diff with no significant difference?

The site has a domain, but it didn’t worked before any domain pointed too. The other server (the one that works) don’t have any domain configured yet.

Is the site that works using a FQDN or is it also using “localdomain”?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Looks like that you have to open a ticket requesting the SMTP unlock.

https://www.digitalocean.com/community/questions/smtp-impossible#answer_12486